[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v2 1/9] monitor/hmp: uninline add_init_drive
From: |
Maxim Levitsky |
Subject: |
[PATCH v2 1/9] monitor/hmp: uninline add_init_drive |
Date: |
Fri, 22 Nov 2019 18:47:59 +0200 |
This is only used by hmp_drive_add.
The code is just a bit shorter this way.
No functional changes
Signed-off-by: Maxim Levitsky <address@hidden>
---
device-hotplug.c | 33 +++++++++++++--------------------
1 file changed, 13 insertions(+), 20 deletions(-)
diff --git a/device-hotplug.c b/device-hotplug.c
index f01d53774b..5ce73f0cff 100644
--- a/device-hotplug.c
+++ b/device-hotplug.c
@@ -34,42 +34,35 @@
#include "monitor/monitor.h"
#include "block/block_int.h"
-static DriveInfo *add_init_drive(const char *optstr)
+
+void hmp_drive_add(Monitor *mon, const QDict *qdict)
{
Error *err = NULL;
- DriveInfo *dinfo;
+ DriveInfo *dinfo = NULL;
QemuOpts *opts;
MachineClass *mc;
+ const char *optstr = qdict_get_str(qdict, "opts");
+ bool node = qdict_get_try_bool(qdict, "node", false);
+
+ if (node) {
+ hmp_drive_add_node(mon, optstr);
+ return;
+ }
opts = drive_def(optstr);
if (!opts)
- return NULL;
+ return;
mc = MACHINE_GET_CLASS(current_machine);
dinfo = drive_new(opts, mc->block_default_type, &err);
if (err) {
error_report_err(err);
qemu_opts_del(opts);
- return NULL;
- }
-
- return dinfo;
-}
-
-void hmp_drive_add(Monitor *mon, const QDict *qdict)
-{
- DriveInfo *dinfo = NULL;
- const char *opts = qdict_get_str(qdict, "opts");
- bool node = qdict_get_try_bool(qdict, "node", false);
-
- if (node) {
- hmp_drive_add_node(mon, opts);
- return;
+ goto err;
}
- dinfo = add_init_drive(opts);
if (!dinfo) {
- goto err;
+ return;
}
switch (dinfo->type) {
--
2.17.2
- [PATCH v2 0/9] RFC: [for 5.0]: HMP monitor handlers cleanups, Maxim Levitsky, 2019/11/22
- [PATCH v2 1/9] monitor/hmp: uninline add_init_drive,
Maxim Levitsky <=
- [PATCH v2 2/9] monitor/hmp: rename device-hotplug.c to block/monitor/block-hmp-cmds.c, Maxim Levitsky, 2019/11/22
- [PATCH v2 3/9] monitor/hmp: move hmp_drive_del and hmp_commit to block-hmp-cmds.c, Maxim Levitsky, 2019/11/22
- [PATCH v2 9/9] monitor/hmp: Prefer to use hmp_handle_error for error reporting in block hmp commands, Maxim Levitsky, 2019/11/22
- [PATCH v2 5/9] monitor/hmp: move hmp_block_job* to block-hmp-cmds.c, Maxim Levitsky, 2019/11/22
- [PATCH v2 4/9] monitor/hmp: move hmp_drive_mirror and hmp_drive_backup to block-hmp-cmds.c, Maxim Levitsky, 2019/11/22
- [PATCH v2 7/9] monitor/hmp: move remaining hmp_block* functions to block-hmp-cmds.c, Maxim Levitsky, 2019/11/22
- [PATCH v2 6/9] monitor/hmp: move hmp_snapshot_* to block-hmp-cmds.c, Maxim Levitsky, 2019/11/22
- [PATCH v2 8/9] monitor/hmp: move hmp_info_block* to block-hmp-cmds.c, Maxim Levitsky, 2019/11/22
- Re: [PATCH v2 0/9] RFC: [for 5.0]: HMP monitor handlers cleanups, Dr. David Alan Gilbert, 2019/11/22