[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v3 17/39] pci: pci_create(), pci_create_multifunction() are now u
From: |
Markus Armbruster |
Subject: |
[PATCH v3 17/39] pci: pci_create(), pci_create_multifunction() are now unused, drop |
Date: |
Tue, 9 Jun 2020 18:39:10 +0200 |
Cc: Michael S. Tsirkin <mst@redhat.com>
Cc: Marcel Apfelbaum <marcel.apfelbaum@gmail.com>
Signed-off-by: Markus Armbruster <armbru@redhat.com>
Reviewed-by: Paolo Bonzini <pbonzini@redhat.com>
---
include/hw/pci/pci.h | 3 ---
hw/pci/pci.c | 16 ----------------
2 files changed, 19 deletions(-)
diff --git a/include/hw/pci/pci.h b/include/hw/pci/pci.h
index 66f8ba519b..a4e9c33416 100644
--- a/include/hw/pci/pci.h
+++ b/include/hw/pci/pci.h
@@ -717,12 +717,9 @@ PCIDevice *pci_new_multifunction(int devfn, bool
multifunction,
PCIDevice *pci_new(int devfn, const char *name);
bool pci_realize_and_unref(PCIDevice *dev, PCIBus *bus, Error **errp);
-PCIDevice *pci_create_multifunction(PCIBus *bus, int devfn, bool multifunction,
- const char *name);
PCIDevice *pci_create_simple_multifunction(PCIBus *bus, int devfn,
bool multifunction,
const char *name);
-PCIDevice *pci_create(PCIBus *bus, int devfn, const char *name);
PCIDevice *pci_create_simple(PCIBus *bus, int devfn, const char *name);
void lsi53c8xx_handle_legacy_cmdline(DeviceState *lsi_dev);
diff --git a/hw/pci/pci.c b/hw/pci/pci.c
index ab8b71fe72..aaffbd7f94 100644
--- a/hw/pci/pci.c
+++ b/hw/pci/pci.c
@@ -2168,17 +2168,6 @@ bool pci_realize_and_unref(PCIDevice *dev, PCIBus *bus,
Error **errp)
return qdev_realize_and_unref(&dev->qdev, &bus->qbus, errp);
}
-PCIDevice *pci_create_multifunction(PCIBus *bus, int devfn, bool multifunction,
- const char *name)
-{
- DeviceState *dev;
-
- dev = qdev_create(&bus->qbus, name);
- qdev_prop_set_int32(dev, "addr", devfn);
- qdev_prop_set_bit(dev, "multifunction", multifunction);
- return PCI_DEVICE(dev);
-}
-
PCIDevice *pci_create_simple_multifunction(PCIBus *bus, int devfn,
bool multifunction,
const char *name)
@@ -2188,11 +2177,6 @@ PCIDevice *pci_create_simple_multifunction(PCIBus *bus,
int devfn,
return dev;
}
-PCIDevice *pci_create(PCIBus *bus, int devfn, const char *name)
-{
- return pci_create_multifunction(bus, devfn, false, name);
-}
-
PCIDevice *pci_create_simple(PCIBus *bus, int devfn, const char *name)
{
return pci_create_simple_multifunction(bus, devfn, false, name);
--
2.26.2
- [PATCH v3 37/39] macio: Convert use of qdev_set_parent_bus(), (continued)
- [PATCH v3 37/39] macio: Convert use of qdev_set_parent_bus(), Markus Armbruster, 2020/06/09
- [PATCH v3 35/39] qom: Tidy up a few object_initialize_child() calls, Markus Armbruster, 2020/06/09
- [PATCH v3 26/39] usb: New usb_new(), usb_realize_and_unref(), Markus Armbruster, 2020/06/09
- [PATCH v3 09/39] qdev: Convert uses of qdev_create() with Coccinelle, Markus Armbruster, 2020/06/09
- [PATCH v3 02/39] Revert "hw/prep: realize the PCI root bus as part of the prep init", Markus Armbruster, 2020/06/09
- [PATCH v3 38/39] macio: Eliminate macio_init_child_obj(), Markus Armbruster, 2020/06/09
- [PATCH v3 34/39] auxbus: Eliminate aux_create_slave(), Markus Armbruster, 2020/06/09
- [PATCH v3 28/39] usb: usb_create() is now unused, drop, Markus Armbruster, 2020/06/09
- [PATCH v3 33/39] auxbus: Convert a use of qdev_set_parent_bus(), Markus Armbruster, 2020/06/09
- [PATCH v3 29/39] usb: Eliminate usb_try_create_simple(), Markus Armbruster, 2020/06/09
- [PATCH v3 17/39] pci: pci_create(), pci_create_multifunction() are now unused, drop,
Markus Armbruster <=
- [PATCH v3 13/39] pci: New pci_new(), pci_realize_and_unref() etc., Markus Armbruster, 2020/06/09
- [PATCH v3 22/39] ssi: ssi_auto_connect_slaves() never does anything, drop, Markus Armbruster, 2020/06/09
- [PATCH v3 27/39] usb: Convert uses of usb_create(), Markus Armbruster, 2020/06/09
- [PATCH v3 11/39] qdev: Convert uses of qdev_set_parent_bus() with Coccinelle, Markus Armbruster, 2020/06/09
- [PATCH v3 04/39] qdev: New qdev_new(), qdev_realize(), etc., Markus Armbruster, 2020/06/09
- [PATCH v3 39/39] sysbus: Drop useless OBJECT() in sysbus_init_child_obj() calls, Markus Armbruster, 2020/06/09
- [PATCH v3 36/39] qom: Less verbose object_initialize_child(), Markus Armbruster, 2020/06/09
- [PATCH v3 31/39] auxbus: Rename aux_init_bus() to aux_bus_init(), Markus Armbruster, 2020/06/09
- [PATCH v3 20/39] isa: Convert uses of isa_create(), isa_try_create() manually, Markus Armbruster, 2020/06/09
- Re: [PATCH v3 00/39] qdev: Rework how we plug into the parent bus, Markus Armbruster, 2020/06/09