[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v7 09/42] target/arm: Implement the IRG instruction
From: |
Peter Maydell |
Subject: |
Re: [PATCH v7 09/42] target/arm: Implement the IRG instruction |
Date: |
Thu, 18 Jun 2020 12:48:15 +0100 |
On Wed, 3 Jun 2020 at 02:13, Richard Henderson
<richard.henderson@linaro.org> wrote:
>
> Signed-off-by: Richard Henderson <richard.henderson@linaro.org>
> ---
> v2: Update to 00eac5.
> Merge choose_random_nonexcluded_tag into helper_irg since
> that pseudo function no longer exists separately.
> v6: Remove obsolete logical/physical tag distinction;
> implement inline for !ATA.
> ---
> +static int choose_nonexcluded_tag(int tag, int offset, uint16_t exclude)
> +{
> + if (exclude == 0xffff) {
> + return 0;
> + }
> + if (offset == 0) {
> + while (exclude & (1 << tag)) {
> + tag = (tag + 1) & 15;
> + }
> + } else {
> + do {
> + do {
> + tag = (tag + 1) & 15;
> + } while (exclude & (1 << tag));
> + } while (--offset > 0);
> + }
Not the way the pseudocode is phrased, but the effect seems to
be the same.
Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
thanks
-- PMM
- Re: [PATCH v7 04/42] target/arm: Add support for MTE to HCR_EL2 and SCR_EL3, (continued)
- [PATCH v7 06/42] target/arm: Add DISAS_UPDATE_NOCHAIN, Richard Henderson, 2020/06/02
- [PATCH v7 05/42] target/arm: Rename DISAS_UPDATE to DISAS_UPDATE_EXIT, Richard Henderson, 2020/06/02
- [PATCH v7 07/42] target/arm: Add MTE system registers, Richard Henderson, 2020/06/02
- [PATCH v7 08/42] target/arm: Add MTE bits to tb_flags, Richard Henderson, 2020/06/02
- [PATCH v7 09/42] target/arm: Implement the IRG instruction, Richard Henderson, 2020/06/02
- Re: [PATCH v7 09/42] target/arm: Implement the IRG instruction,
Peter Maydell <=
- [PATCH v7 10/42] target/arm: Implement the ADDG, SUBG instructions, Richard Henderson, 2020/06/02
- [PATCH v7 11/42] target/arm: Implement the GMI instruction, Richard Henderson, 2020/06/02
- [PATCH v7 12/42] target/arm: Implement the SUBP instruction, Richard Henderson, 2020/06/02
- [PATCH v7 13/42] target/arm: Define arm_cpu_do_unaligned_access for user-only, Richard Henderson, 2020/06/02