qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 46/63] renesas: Rename RTMR to RENESAS_TMR


From: Eduardo Habkost
Subject: [PATCH 46/63] renesas: Rename RTMR to RENESAS_TMR
Date: Wed, 2 Sep 2020 18:42:54 -0400

This will make the type name constant consistent with the name of
the type checking macro.

Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: Yoshinori Sato <ysato@users.sourceforge.jp>
Cc: Magnus Damm <magnus.damm@gmail.com>
Cc: qemu-devel@nongnu.org
---
 include/hw/timer/renesas_tmr.h | 6 +++---
 hw/rx/rx62n.c                  | 2 +-
 hw/timer/renesas_tmr.c         | 6 +++---
 3 files changed, 7 insertions(+), 7 deletions(-)

diff --git a/include/hw/timer/renesas_tmr.h b/include/hw/timer/renesas_tmr.h
index caf7eec0dc..5f2f156160 100644
--- a/include/hw/timer/renesas_tmr.h
+++ b/include/hw/timer/renesas_tmr.h
@@ -13,10 +13,10 @@
 #include "hw/sysbus.h"
 #include "qom/object.h"
 
-#define TYPE_RENESAS_TMR "renesas-tmr"
+#define TYPE_RTMR "renesas-tmr"
 typedef struct RTMRState RTMRState;
-DECLARE_INSTANCE_CHECKER(RTMRState, RTMR,
-                         TYPE_RENESAS_TMR)
+DECLARE_INSTANCE_CHECKER(RTMRState, RENESAS_TMR,
+                         TYPE_RTMR)
 
 enum timer_event {
     cmia = 0,
diff --git a/hw/rx/rx62n.c b/hw/rx/rx62n.c
index 6eb4eea700..0f564c4dfb 100644
--- a/hw/rx/rx62n.c
+++ b/hw/rx/rx62n.c
@@ -166,7 +166,7 @@ static void register_tmr(RX62NState *s, int unit)
     int i, irqbase;
 
     object_initialize_child(OBJECT(s), "tmr[*]",
-                            &s->tmr[unit], TYPE_RENESAS_TMR);
+                            &s->tmr[unit], TYPE_RTMR);
     tmr = SYS_BUS_DEVICE(&s->tmr[unit]);
     qdev_prop_set_uint64(DEVICE(tmr), "input-freq", s->pclk_freq_hz);
     sysbus_realize(tmr, &error_abort);
diff --git a/hw/timer/renesas_tmr.c b/hw/timer/renesas_tmr.c
index 446f2eacdd..53733586c2 100644
--- a/hw/timer/renesas_tmr.c
+++ b/hw/timer/renesas_tmr.c
@@ -396,7 +396,7 @@ static void timer_event1(void *opaque)
 
 static void rtmr_reset(DeviceState *dev)
 {
-    RTMRState *tmr = RTMR(dev);
+    RTMRState *tmr = RENESAS_TMR(dev);
     tmr->tcr[0]   = tmr->tcr[1]   = 0x00;
     tmr->tcsr[0]  = 0x00;
     tmr->tcsr[1]  = 0x10;
@@ -411,7 +411,7 @@ static void rtmr_reset(DeviceState *dev)
 static void rtmr_init(Object *obj)
 {
     SysBusDevice *d = SYS_BUS_DEVICE(obj);
-    RTMRState *tmr = RTMR(obj);
+    RTMRState *tmr = RENESAS_TMR(obj);
     int i;
 
     memory_region_init_io(&tmr->memory, OBJECT(tmr), &tmr_ops,
@@ -462,7 +462,7 @@ static void rtmr_class_init(ObjectClass *klass, void *data)
 }
 
 static const TypeInfo rtmr_info = {
-    .name = TYPE_RENESAS_TMR,
+    .name = TYPE_RTMR,
     .parent = TYPE_SYS_BUS_DEVICE,
     .instance_size = sizeof(RTMRState),
     .instance_init = rtmr_init,
-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]