qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 53/63] usb: Rename USB_SERIAL_DEV to USB_SERIAL


From: Philippe Mathieu-Daudé
Subject: Re: [PATCH 53/63] usb: Rename USB_SERIAL_DEV to USB_SERIAL
Date: Thu, 3 Sep 2020 15:04:18 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 9/3/20 12:43 AM, Eduardo Habkost wrote:
> Make the type checking macro name consistent with the TYPE_*
> constant.
> 
> Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>

Reviewed-by: Philippe Mathieu-Daudé <philmd@redhat.com>

> ---
> Cc: Gerd Hoffmann <kraxel@redhat.com>
> Cc: Samuel Thibault <samuel.thibault@ens-lyon.org>
> Cc: qemu-devel@nongnu.org
> ---
>  hw/usb/dev-serial.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/hw/usb/dev-serial.c b/hw/usb/dev-serial.c
> index 1a58851d4b..1a038a222e 100644
> --- a/hw/usb/dev-serial.c
> +++ b/hw/usb/dev-serial.c
> @@ -113,7 +113,7 @@ struct USBSerialState {
>  typedef struct USBSerialState USBSerialState;
>  
>  #define TYPE_USB_SERIAL "usb-serial-dev"
> -DECLARE_INSTANCE_CHECKER(USBSerialState, USB_SERIAL_DEV,
> +DECLARE_INSTANCE_CHECKER(USBSerialState, USB_SERIAL,
>                           TYPE_USB_SERIAL)
>  
>  enum {
> @@ -517,7 +517,7 @@ static void usb_serial_event(void *opaque, QEMUChrEvent 
> event)
>  
>  static void usb_serial_realize(USBDevice *dev, Error **errp)
>  {
> -    USBSerialState *s = USB_SERIAL_DEV(dev);
> +    USBSerialState *s = USB_SERIAL(dev);
>      Error *local_err = NULL;
>  
>      usb_desc_create_serial(dev);
> 




reply via email to

[Prev in Thread] Current Thread [Next in Thread]