qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[PATCH 2/8] i8254: Rename PIT to ISA_PIT


From: Eduardo Habkost
Subject: [PATCH 2/8] i8254: Rename PIT to ISA_PIT
Date: Thu, 3 Sep 2020 14:01:22 -0400

Rename type checking function to be consistent with the type name
constant (TYPE_ISA_PIT) and type name string ("isa-pit").

Suggested-by: "Daniel P. Berrangé" <berrange@redhat.com>
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
---
Cc: "Michael S. Tsirkin" <mst@redhat.com>
Cc: Paolo Bonzini <pbonzini@redhat.com>
Cc: qemu-devel@nongnu.org
---
 hw/timer/i8254.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/hw/timer/i8254.c b/hw/timer/i8254.c
index 5666bcb4ef..3f63e7b936 100644
--- a/hw/timer/i8254.c
+++ b/hw/timer/i8254.c
@@ -38,7 +38,7 @@
 #define RW_STATE_WORD1 4
 
 typedef struct PITClass PITClass;
-DECLARE_CLASS_CHECKERS(PITClass, PIT,
+DECLARE_CLASS_CHECKERS(PITClass, ISA_PIT,
                        TYPE_ISA_PIT)
 
 struct PITClass {
@@ -334,7 +334,7 @@ static void pit_post_load(PITCommonState *s)
 static void pit_realizefn(DeviceState *dev, Error **errp)
 {
     PITCommonState *pit = PIT_COMMON(dev);
-    PITClass *pc = PIT_GET_CLASS(dev);
+    PITClass *pc = ISA_PIT_GET_CLASS(dev);
     PITChannelState *s;
 
     s = &pit->channels[0];
@@ -357,7 +357,7 @@ static Property pit_properties[] = {
 
 static void pit_class_initfn(ObjectClass *klass, void *data)
 {
-    PITClass *pc = PIT_CLASS(klass);
+    PITClass *pc = ISA_PIT_CLASS(klass);
     PITCommonClass *k = PIT_COMMON_CLASS(klass);
     DeviceClass *dc = DEVICE_CLASS(klass);
 
-- 
2.26.2




reply via email to

[Prev in Thread] Current Thread [Next in Thread]