qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 16/29] block/export: Allocate BlockExport in blk_exp_add()


From: Max Reitz
Subject: Re: [PATCH 16/29] block/export: Allocate BlockExport in blk_exp_add()
Date: Wed, 16 Sep 2020 12:56:44 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Thunderbird/68.11.0

On 07.09.20 20:19, Kevin Wolf wrote:
> Instead of letting the driver allocate and return the BlockExport
> object, allocate it already in blk_exp_add() and pass it. This allows us
> to initialise the generic part before calling into the driver so that
> the driver can just use these values instead of having to parse the
> options a second time.
> 
> For symmetry, move freeing the BlockExport to blk_exp_unref().
> 
> Signed-off-by: Kevin Wolf <kwolf@redhat.com>
> Reviewed-by: Max Reitz <mreitz@redhat.com>
> ---
>  include/block/export.h |  8 +++++++-
>  include/block/nbd.h    | 11 ++++++-----
>  block/export/export.c  | 18 +++++++++++++++++-
>  blockdev-nbd.c         | 26 ++++++++++++++------------
>  nbd/server.c           | 30 +++++++++++++-----------------
>  5 files changed, 57 insertions(+), 36 deletions(-)

[...]

> diff --git a/block/export/export.c b/block/export/export.c
> index 8635318ef1..03ff155f97 100644
> --- a/block/export/export.c
> +++ b/block/export/export.c
> @@ -39,6 +39,8 @@ static const BlockExportDriver 
> *blk_exp_find_driver(BlockExportType type)
>  BlockExport *blk_exp_add(BlockExportOptions *export, Error **errp)
>  {
>      const BlockExportDriver *drv;
> +    BlockExport *exp;
> +    int ret;
>  
>      drv = blk_exp_find_driver(export->type);
>      if (!drv) {
> @@ -46,7 +48,20 @@ BlockExport *blk_exp_add(BlockExportOptions *export, Error 
> **errp)
>          return NULL;
>      }
>  
> -    return drv->create(export, errp);
> +    assert(drv->instance_size >= sizeof(BlockExport));
> +    exp = g_malloc0(drv->instance_size);
> +    *exp = (BlockExport) {
> +        .drv        = &blk_exp_nbd,

Only noticed now when trying to base my FUSE stuff on this series:
s/blk_exp_nbd/drv/.

(I’d like to say “obviously”, but, well.  Evidently not obvious enough
for me.)

Max

Attachment: signature.asc
Description: OpenPGP digital signature


reply via email to

[Prev in Thread] Current Thread [Next in Thread]