qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH 0/9] Alpine Linux build fix and CI pipeline


From: Jiaxun Yang
Subject: Re: [PATCH 0/9] Alpine Linux build fix and CI pipeline
Date: Wed, 23 Dec 2020 08:54:57 +0800
User-agent: Cyrus-JMAP/3.3.1-61-gb52c239-fm-20201210.001-gb52c2396


On Wed, Dec 23, 2020, at 2:41 AM, Wainer dos Santos Moschetta wrote:
> Hi,
> 
> On 12/21/20 5:25 AM, Jiaxun Yang wrote:
> >
> > On Mon, Dec 21, 2020, at 9:06 AM, no-reply@patchew.org wrote:
> >> Patchew URL:
> >> 20201221005318.11866-1-jiaxun.yang@flygoat.com/">https://patchew.org/QEMU/20201221005318.11866-1-jiaxun.yang@flygoat.com/
> >>
> >>
> >>
> >> Hi,
> >>
> >> This series seems to have some coding style problems. See output below for
> >> more information:
> >>
> >> Type: series
> >> Message-id: 20201221005318.11866-1-jiaxun.yang@flygoat.com
> >> Subject: [PATCH 0/9] Alpine Linux build fix and CI pipeline
> >>
> >> === TEST SCRIPT BEGIN ===
> >> #!/bin/bash
> >> git rev-parse base > /dev/null || exit 0
> >> git config --local diff.renamelimit 0
> >> git config --local diff.renames True
> >> git config --local diff.algorithm histogram
> >> ./scripts/checkpatch.pl --mailback base..
> >> === TEST SCRIPT END ===
> >>
> >> Updating 3c8cf5a9c21ff8782164d1def7f44bd888713384
> >>  From https://github.com/patchew-project/qemu
> >>   * [new tag]
> >> patchew/20201221005318.11866-1-jiaxun.yang@flygoat.com ->
> >> patchew/20201221005318.11866-1-jiaxun.yang@flygoat.com
> >> Switched to a new branch 'test'
> >> 10095a9 gitlab-ci: Add alpine to pipeline
> >> a177af3 tests: Rename PAGE_SIZE definitions
> >> 5fcb0ed accel/kvm: avoid using predefined PAGE_SIZE
> >> e7febdf hw/block/nand: Rename PAGE_SIZE to NAND_PAGE_SIZE
> >> ba307d5 elf2dmp: Rename PAGE_SIZE to ELF2DMP_PAGE_SIZE
> >> 0ccf92b libvhost-user: Include poll.h instead of sys/poll.h
> >> 41a10db configure/meson: Only check sys/signal.h on non-Linux
> >> 0bcd2f2 configure: Add sys/timex.h to probe clk_adjtime
> >> a16c7ff tests/docker: Add dockerfile for Alpine Linux
> >>
> >> === OUTPUT BEGIN ===
> >> 1/9 Checking commit a16c7ff7d859 (tests/docker: Add dockerfile for Alpine 
> >> Linux)
> >> WARNING: added, moved or deleted file(s), does MAINTAINERS need updating?
> >> #20:
> >> new file mode 100644
> >>
> >> total: 0 errors, 1 warnings, 56 lines checked
> >>
> >> Patch 1/9 has style problems, please review.  If any of these errors
> >> are false positives report them to the maintainer, see
> >> CHECKPATCH in MAINTAINERS.
> >> 2/9 Checking commit 0bcd2f2eae84 (configure: Add sys/timex.h to probe
> >> clk_adjtime)
> >> 3/9 Checking commit 41a10dbdc8da (configure/meson: Only check
> >> sys/signal.h on non-Linux)
> >> 4/9 Checking commit 0ccf92b8ec37 (libvhost-user: Include poll.h instead
> >> of sys/poll.h)
> >> 5/9 Checking commit ba307d5a51aa (elf2dmp: Rename PAGE_SIZE to
> >> ELF2DMP_PAGE_SIZE)
> >> WARNING: line over 80 characters
> >> #69: FILE: contrib/elf2dmp/main.c:284:
> >> +        h.PhysicalMemoryBlock.NumberOfPages += ps->block[i].size /
> >> ELF2DMP_PAGE_SIZE;
> >>
> >> WARNING: line over 80 characters
> >> #79: FILE: contrib/elf2dmp/main.c:291:
> >> +    h.RequiredDumpSpace += h.PhysicalMemoryBlock.NumberOfPages <<
> >> ELF2DMP_PAGE_BITS;
> >>
> >> total: 0 errors, 2 warnings, 70 lines checked
> >>
> >> Patch 5/9 has style problems, please review.  If any of these errors
> >> are false positives report them to the maintainer, see
> >> CHECKPATCH in MAINTAINERS.
> >> 6/9 Checking commit e7febdf0b056 (hw/block/nand: Rename PAGE_SIZE to
> >> NAND_PAGE_SIZE)
> >> ERROR: code indent should never use tabs
> >> #26: FILE: hw/block/nand.c:117:
> >> +# define PAGE_START(page)^I(PAGE(page) * (NAND_PAGE_SIZE + OOB_SIZE))$
> >>
> >> ERROR: code indent should never use tabs
> >> #46: FILE: hw/block/nand.c:134:
> >> +# define NAND_PAGE_SIZE^I^I2048$
> >>
> >> WARNING: line over 80 characters
> >> #65: FILE: hw/block/nand.c:684:
> >> +        mem_and(iobuf + (soff | off), s->io, MIN(s->iolen,
> >> NAND_PAGE_SIZE - off));
> >>
> >> WARNING: line over 80 characters
> >> #70: FILE: hw/block/nand.c:687:
> >> +            mem_and(s->storage + (page << OOB_SHIFT), s->io +
> >> NAND_PAGE_SIZE - off,
> >>
> >> total: 2 errors, 2 warnings, 120 lines checked
> >>
> >> Patch 6/9 has style problems, please review.  If any of these errors
> >> are false positives report them to the maintainer, see
> >> CHECKPATCH in MAINTAINERS.
> >>
> >> 7/9 Checking commit 5fcb0ed1331a (accel/kvm: avoid using predefined 
> >> PAGE_SIZE)
> >> 8/9 Checking commit a177af33938d (tests: Rename PAGE_SIZE definitions)
> >> 9/9 Checking commit 10095a92643d (gitlab-ci: Add alpine to pipeline)
> >> === OUTPUT END ===
> >>
> >> Test command exited with code: 1
> > All pre-existing errors.
> 
> Apparently some style errors were introduced by the patches 05 and 06.

I'm just doing string replacement, should I add a patch separately to fix 
existing issues than replace the string?

Thanks.

> 
> - Wainer
> 
> >
> >>
> >> The full log is available at
> >> 20201221005318.11866-1-jiaxun.yang@flygoat.com/testing.checkpatch/?type=message">http://patchew.org/logs/20201221005318.11866-1-jiaxun.yang@flygoat.com/testing.checkpatch/?type=message.
> >> ---
> >> Email generated automatically by Patchew [https://patchew.org/].
> >> Please send your feedback to patchew-devel@redhat.com
> 
>

-- 
- Jiaxun



reply via email to

[Prev in Thread] Current Thread [Next in Thread]