qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v2 14/15] bsd-user: Rename sigqueue to qemu_sigqueue


From: Kyle Evans
Subject: Re: [PATCH v2 14/15] bsd-user: Rename sigqueue to qemu_sigqueue
Date: Sun, 17 Oct 2021 22:36:57 -0500

On Fri, Oct 8, 2021 at 6:15 PM Warner Losh <imp@bsdimp.com> wrote:
>
> To avoid a name clash with FreeBSD's sigqueue data structure in
> signalvar.h, rename sigqueue to qemu_sigqueue. This sturcture

s/sturcture/structure/

> is currently defined, but unused.
>
> Signed-off-by: Warner Losh <imp@bsdimp.com>
> Reviewed-by: Richard Henderson <richard.henderson@linaro.org>
> Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
> ---
>  bsd-user/qemu.h | 14 +++++++-------
>  1 file changed, 7 insertions(+), 7 deletions(-)
>
> diff --git a/bsd-user/qemu.h b/bsd-user/qemu.h
> index e65e41d53d..5b815c3a23 100644
> --- a/bsd-user/qemu.h
> +++ b/bsd-user/qemu.h
> @@ -73,15 +73,15 @@ struct image_info {
>
>  #define MAX_SIGQUEUE_SIZE 1024
>
> -struct sigqueue {
> -    struct sigqueue *next;
> +struct qemu_sigqueue {
> +    struct qemu_sigqueue *next;
> +    target_siginfo_t info;
>  };
>
>  struct emulated_sigtable {
>      int pending; /* true if signal is pending */
> -    struct sigqueue *first;
> -    /* in order to always have memory for the first signal, we put it here */
> -    struct sigqueue info;
> +    struct qemu_sigqueue *first;
> +    struct qemu_sigqueue info; /* Put first signal info here */
>  };
>
>  /*
> @@ -95,8 +95,8 @@ typedef struct TaskState {
>      struct image_info *info;
>
>      struct emulated_sigtable sigtab[TARGET_NSIG];
> -    struct sigqueue sigqueue_table[MAX_SIGQUEUE_SIZE]; /* siginfo queue */
> -    struct sigqueue *first_free; /* first free siginfo queue entry */
> +    struct qemu_sigqueue sigqueue_table[MAX_SIGQUEUE_SIZE]; /* siginfo queue 
> */
> +    struct qemu_sigqueue *first_free; /* first free siginfo queue entry */
>      int signal_pending; /* non zero if a signal may be pending */
>
>      uint8_t stack[];
> --
> 2.32.0
>

Typo noted above in the commit message; otherwise:

Reviewed-by: Kyle Evans <kevans@FreeBSD.org>



reply via email to

[Prev in Thread] Current Thread [Next in Thread]