qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PULL 00/30] Renesas SH-4 patches for 2021-10-30


From: Richard Henderson
Subject: Re: [PULL 00/30] Renesas SH-4 patches for 2021-10-30
Date: Sat, 30 Oct 2021 13:13:11 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Thunderbird/78.13.0

On 10/30/21 10:05 AM, Philippe Mathieu-Daudé wrote:
The following changes since commit dd61b91c080cdfba1360a5ea1e4693fffb3445b0:

   Merge remote-tracking branch 'remotes/armbru/tags/pull-qapi-2021-10-29' into 
staging (2021-10-29 19:42:36 -0700)

are available in the Git repository at:

   https://github.com/philmd/qemu.git tags/renesas-20211030

for you to fetch changes up to 46e44759fc24a05e338cd37a735b4aad5422e717:

   hw/timer/sh_timer: Remove use of hw_error (2021-10-30 18:39:37 +0200)

----------------------------------------------------------------
Renesas SH-4 patches queue

Patches from Zoltan:
- Various clean up to align the code style with the rest of the code base
- QOM'ify the SH_SERIAL device
- Modify few memory region size to better match the hardware manual

----------------------------------------------------------------

BALATON Zoltan (30):
   hw/sh4: Coding style: Remove tabs
   hw/sh4: Coding style: Fix multi-line comments
   hw/sh4: Coding style: White space fixes
   hw/sh4: Coding style: Add missing braces
   hw/sh4: Coding style: Remove unnecessary casts
   hw/sh4: Fix typos in a comment
   hw/sh4: Change debug printfs to traces
   hw/sh4/r2d: Use error_report instead of fprintf to stderr
   hw/char/sh_serial: Do not abort on invalid access
   hw/char/sh_serial: Rename type sh_serial_state to SHSerialState
   hw/char/sh_serial: Embed QEMUTimer in state struct
   hw/char/sh_serial: Split off sh_serial_reset() from sh_serial_init()
   hw/char/sh_serial: QOM-ify
   hw/char/sh_serial: Add device id to trace output
   hw/intc/sh_intc: Use existing macro instead of local one
   hw/intc/sh_intc: Turn some defines into an enum
   hw/intc/sh_intc: Rename iomem region
   hw/intc/sh_intc: Drop another useless macro
   hw/intc/sh_intc: Move sh_intc_register() closer to its only user
   hw/intc/sh_intc: Remove excessive parenthesis
   hw/intc/sh_intc: Use array index instead of pointer arithmetics
   hw/intc/sh_intc: Inline and drop sh_intc_source() function
   hw/intc/sh_intc: Replace abort() with g_assert_not_reached()
   hw/intc/sh_intc: Avoid using continue in loops
   hw/intc/sh_intc: Simplify allocating sources array
   hw/intc/sh_intc: Remove unneeded local variable initialisers
   hw/timer/sh_timer: Rename sh_timer_state to SHTimerState
   hw/timer/sh_timer: Do not wrap lines that are not too long
   hw/timer/sh_timer: Fix timer memory region size
   hw/timer/sh_timer: Remove use of hw_error

  meson.build              |    1 +
  hw/sh4/sh7750_regs.h     | 1528 +++++++++++++++++++-------------------
  hw/sh4/trace.h           |    1 +
  include/hw/sh4/sh.h      |   19 +-
  include/hw/sh4/sh_intc.h |    2 +-
  hw/char/sh_serial.c      |  232 +++---
  hw/intc/sh_intc.c        |  573 +++++++-------
  hw/pci-host/sh_pci.c     |   10 +-
  hw/sh4/r2d.c             |   69 +-
  hw/sh4/sh7750.c          |  631 ++++++++--------
  hw/sh4/sh7750_regnames.c |  148 ++--
  hw/sh4/shix.c            |   12 +-
  hw/timer/sh_timer.c      |  151 ++--
  hw/char/trace-events     |    4 +
  hw/intc/trace-events     |    8 +
  hw/sh4/trace-events      |    3 +
  hw/timer/trace-events    |    5 +
  17 files changed, 1713 insertions(+), 1684 deletions(-)
  create mode 100644 hw/sh4/trace.h
  create mode 100644 hw/sh4/trace-events

Applied, thanks.

r~




reply via email to

[Prev in Thread] Current Thread [Next in Thread]