qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v7 11/14] KVM: Register/unregister the guest private memory r


From: Chao Peng
Subject: Re: [PATCH v7 11/14] KVM: Register/unregister the guest private memory regions
Date: Thu, 21 Jul 2022 17:29:06 +0800

On Thu, Jul 21, 2022 at 03:34:59PM +0800, Wei Wang wrote:
> 
> 
> On 7/21/22 00:21, Sean Christopherson wrote:
> > On Wed, Jul 20, 2022, Gupta, Pankaj wrote:
> > > > > > > > +bool __weak kvm_arch_private_mem_supported(struct kvm *kvm)
> > Use kvm_arch_has_private_mem(), both because "has" makes it obvious this is 
> > checking
> > a flag of sorts, and to align with other helpers of this nature (and with
> > CONFIG_HAVE_KVM_PRIVATE_MEM).
> > 
> >    $ git grep kvm_arch | grep supported | wc -l
> >    0
> >    $ git grep kvm_arch | grep has | wc -l
> >    26

Make sense. kvm_arch_has_private_mem it actually better.

> > 
> > > > > > > > +#ifdef CONFIG_HAVE_KVM_PRIVATE_MEM
> > > > > > > > +       case KVM_MEMORY_ENCRYPT_REG_REGION:
> > > > > > > > +       case KVM_MEMORY_ENCRYPT_UNREG_REGION: {
> > > > > > > > +               struct kvm_enc_region region;
> > > > > > > > +
> > > > > > > > +               if (!kvm_arch_private_mem_supported(kvm))
> > > > > > > > +                       goto arch_vm_ioctl;
> > > > > > > > +
> > > > > > > > +               r = -EFAULT;
> > > > > > > > +               if (copy_from_user(&region, argp, 
> > > > > > > > sizeof(region)))
> > > > > > > > +                       goto out;
> > > > > > > > +
> > > > > > > > +               r = kvm_vm_ioctl_set_encrypted_region(kvm, 
> > > > > > > > ioctl, &region);
> > > > > > > this is to store private region metadata not only the encrypted 
> > > > > > > region?
> > > > > > Correct.
> > > > > Sorry for not being clear, was suggesting name change of this 
> > > > > function from:
> > > > > "kvm_vm_ioctl_set_encrypted_region" to 
> > > > > "kvm_vm_ioctl_set_private_region"
> > > > Though I don't have strong reason to change it, I'm fine with this and
> > > Yes, no strong reason, just thought "kvm_vm_ioctl_set_private_region" 
> > > would
> > > depict the actual functionality :)
> > > 
> > > > this name matches the above kvm_arch_private_mem_supported perfectly.
> > > BTW could not understand this, how "kvm_vm_ioctl_set_encrypted_region"
> > > matches "kvm_arch_private_mem_supported"?
> > Chao is saying that kvm_vm_ioctl_set_private_region() pairs nicely with
> > kvm_arch_private_mem_supported(), not that the "encrypted" variant pairs 
> > nicely.
> > 
> > I also like using "private" instead of "encrypted", though we should 
> > probably
> > find a different verb than "set", because calling "set_private" when making 
> > the
> > region shared is confusing.  I'm struggling to come up with a good 
> > alternative
> > though.
> > 
> > kvm_vm_ioctl_set_memory_region() is already taken by 
> > KVM_SET_USER_MEMORY_REGION,
> > and that also means that anything with "memory_region" in the name is bound 
> > to be
> > confusing.
> > 
> > Hmm, and if we move away from "encrypted", it probably makes sense to pass 
> > in
> > addr+size instead of a kvm_enc_region.

This makes sense.

> > 
> > Maybe this?
> > 
> > static int kvm_vm_ioctl_set_or_clear_mem_private(struct kvm *kvm, gpa_t gpa,
> >                                              gpa_t size, bool set_private)

Currently this should work.

> > 
> > and then:
> > 
> > #ifdef CONFIG_HAVE_KVM_PRIVATE_MEM
> >     case KVM_MEMORY_ENCRYPT_REG_REGION:
> >     case KVM_MEMORY_ENCRYPT_UNREG_REGION: {
> >             bool set = ioctl == KVM_MEMORY_ENCRYPT_REG_REGION;
> >             struct kvm_enc_region region;
> > 
> >             if (!kvm_arch_private_mem_supported(kvm))
> >                     goto arch_vm_ioctl;
> > 
> >             r = -EFAULT;
> >             if (copy_from_user(&region, argp, sizeof(region)))
> >                     goto out;
> > 
> >             r = kvm_vm_ioctl_set_or_clear_mem_private(kvm, region.addr,
> >                                                       region.size, set);
> >             break;
> >     }
> > #endif
> > 
> > I don't love it, so if someone has a better idea...
> > 
> Maybe you could tag it with cgs for all the confidential guest support
> related stuff:
> e.g. kvm_vm_ioctl_set_cgs_mem()
> 
> bool is_private = ioctl == KVM_MEMORY_ENCRYPT_REG_REGION;
> ...
> kvm_vm_ioctl_set_cgs_mem(, is_private)

If we plan to widely use such abbr. through KVM (e.g. it's well known),
I'm fine.

I actually use mem_attr in patch: https://lkml.org/lkml/2022/7/20/610
But I also don't quite like it, it's so generic and sounds say nothing.

But I do want a name can cover future usages other than just 
private/shared (pKVM for example may have a third state).

Thanks,
Chao



reply via email to

[Prev in Thread] Current Thread [Next in Thread]