[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v4 0/7] Resolve TYPE_PIIX3_XEN_DEVICE
From: |
Stefano Stabellini |
Subject: |
Re: [PATCH v4 0/7] Resolve TYPE_PIIX3_XEN_DEVICE |
Date: |
Mon, 15 May 2023 13:52:40 -0700 (PDT) |
User-agent: |
Alpine 2.22 (DEB 394 2020-01-19) |
On Sat, 13 May 2023, Bernhard Beschow wrote:
> Am 21. April 2023 07:38:10 UTC schrieb "Michael S. Tsirkin" <mst@redhat.com>:
> >On Mon, Apr 03, 2023 at 09:41:17AM +0200, Bernhard Beschow wrote:
> >> There is currently a dedicated PIIX3 device model for use under Xen. By
> >> reusing
> >> existing PCI API during initialization this device model can be eliminated
> >> and
> >> the plain PIIX3 device model can be used instead.
> >>
> >> Resolving TYPE_PIIX3_XEN_DEVICE results in less code while also making Xen
> >> agnostic towards the precise south bridge being used in the PC machine. The
> >> latter might become particularily interesting once PIIX4 becomes usable in
> >> the
> >> PC machine, avoiding the "Frankenstein" use of PIIX4_ACPI in PIIX3.
> >
> >xen stuff so I assume that tree?
>
> Ping
I am OK either way. Michael, what do you prefer?
Normally I would suggest for you to pick up the patches. But as it
happens I'll have to likely send another pull request in a week or two
and I can add these patches to it.
Let me know your preference and I am happy to follow it.
> >
> >> Testing done:
> >> - `make check`
> >> - Run `xl create` with the following config:
> >> name = "Manjaro"
> >> type = 'hvm'
> >> memory = 1536
> >> apic = 1
> >> usb = 1
> >> disk = [ "file:manjaro-kde-21.2.6-220416-linux515.iso,hdc:cdrom,r" ]
> >> device_model_override = "/usr/bin/qemu-system-x86_64"
> >> vga = "stdvga"
> >> sdl = 1
> >> - `qemu-system-x86_64 -M pc -m 2G -cpu host -accel kvm \
> >> -cdrom manjaro-kde-21.2.6-220416-linux515.iso`
> >>
> >> v4:
> >> - Add patch fixing latent memory leak in pci_bus_irqs() (Anthony)
> >>
> >> v3:
> >> - Rebase onto master
> >>
> >> v2:
> >> - xen_piix3_set_irq() is already generic. Just rename it. (Chuck)
> >>
> >> Tested-by: Chuck Zmudzinski <brchuckz@aol.com>
> >>
> >> Bernhard Beschow (7):
> >> include/hw/xen/xen: Rename xen_piix3_set_irq() to xen_intx_set_irq()
> >> hw/pci/pci.c: Don't leak PCIBus::irq_count[] in pci_bus_irqs()
> >> hw/isa/piix3: Reuse piix3_realize() in piix3_xen_realize()
> >> hw/isa/piix3: Wire up Xen PCI IRQ handling outside of PIIX3
> >> hw/isa/piix3: Avoid Xen-specific variant of piix3_write_config()
> >> hw/isa/piix3: Resolve redundant k->config_write assignments
> >> hw/isa/piix3: Resolve redundant TYPE_PIIX3_XEN_DEVICE
> >>
> >> include/hw/southbridge/piix.h | 1 -
> >> include/hw/xen/xen.h | 2 +-
> >> hw/i386/pc_piix.c | 36 +++++++++++++++++++--
> >> hw/i386/xen/xen-hvm.c | 2 +-
> >> hw/isa/piix3.c | 60 +----------------------------------
> >> hw/pci/pci.c | 2 ++
> >> stubs/xen-hw-stub.c | 2 +-
> >> 7 files changed, 39 insertions(+), 66 deletions(-)
> >>
> >> --
> >> 2.40.0
> >>
> >
>