qemu-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] hw/ppc/openpic: Do not open-code ROUND_UP() macro


From: Daniel Henrique Barboza
Subject: Re: [PATCH] hw/ppc/openpic: Do not open-code ROUND_UP() macro
Date: Tue, 6 Jun 2023 15:34:09 -0300
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.10.0



On 5/23/23 03:15, Philippe Mathieu-Daudé wrote:
While reviewing, the ROUND_UP() macro is easier to figure out.
Besides, the comment confirms we want to round up here.

Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
---


Queued in gitlab.com/danielhb/qemu/tree/ppc-next. Thanks,


Daniel

  include/hw/ppc/openpic.h | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/include/hw/ppc/openpic.h b/include/hw/ppc/openpic.h
index ebdaf8a493..bae8dafe16 100644
--- a/include/hw/ppc/openpic.h
+++ b/include/hw/ppc/openpic.h
@@ -55,7 +55,7 @@ typedef enum IRQType {
   * Round up to the nearest 64 IRQs so that the queue length
   * won't change when moving between 32 and 64 bit hosts.
   */
-#define IRQQUEUE_SIZE_BITS ((OPENPIC_MAX_IRQ + 63) & ~63)
+#define IRQQUEUE_SIZE_BITS ROUND_UP(OPENPIC_MAX_IRQ, 64)
typedef struct IRQQueue {
      unsigned long *queue;



reply via email to

[Prev in Thread] Current Thread [Next in Thread]