[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH v6 04/15] pcie_sriov: Do not reset NumVFs after disabling VFs
From: |
Akihiko Odaki |
Subject: |
[PATCH v6 04/15] pcie_sriov: Do not reset NumVFs after disabling VFs |
Date: |
Tue, 20 Feb 2024 21:24:39 +0900 |
The spec does not NumVFs is reset after disabling VFs except when
resetting the PF. Clearing it is guest visible and out of spec, even
though Linux doesn't rely on this value being preserved, so we never
noticed.
Fixes: 7c0fa8dff811 ("pcie: Add support for Single Root I/O Virtualization
(SR/IOV)")
Signed-off-by: Akihiko Odaki <akihiko.odaki@daynix.com>
---
hw/pci/pcie_sriov.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/hw/pci/pcie_sriov.c b/hw/pci/pcie_sriov.c
index 51b66d1bb342..e9b23221d713 100644
--- a/hw/pci/pcie_sriov.c
+++ b/hw/pci/pcie_sriov.c
@@ -215,7 +215,6 @@ static void unregister_vfs(PCIDevice *dev)
g_free(dev->exp.sriov_pf.vf);
dev->exp.sriov_pf.vf = NULL;
dev->exp.sriov_pf.num_vfs = 0;
- pci_set_word(dev->config + dev->exp.sriov_cap + PCI_SRIOV_NUM_VF, 0);
}
void pcie_sriov_config_write(PCIDevice *dev, uint32_t address,
@@ -260,6 +259,8 @@ void pcie_sriov_pf_reset(PCIDevice *dev)
pci_set_word(dev->config + sriov_cap + PCI_SRIOV_CTRL, 0);
unregister_vfs(dev);
+ pci_set_word(dev->config + sriov_cap + PCI_SRIOV_NUM_VF, 0);
+
/*
* Default is to use 4K pages, software can modify it
* to any of the supported bits
--
2.43.1
[PATCH v6 02/15] pcie_sriov: Validate NumVFs, Akihiko Odaki, 2024/02/20
[PATCH v6 04/15] pcie_sriov: Do not reset NumVFs after disabling VFs,
Akihiko Odaki <=
[PATCH v6 05/15] hw/pci: Always call pcie_sriov_pf_reset(), Akihiko Odaki, 2024/02/20
[PATCH v6 08/15] pcie_sriov: Reuse SR-IOV VF device instances, Akihiko Odaki, 2024/02/20
[PATCH v6 03/15] pcie_sriov: Reset SR-IOV extended capability, Akihiko Odaki, 2024/02/20
[PATCH v6 06/15] hw/pci: Rename has_power to enabled, Akihiko Odaki, 2024/02/20
[PATCH v6 09/15] pcie_sriov: Release VFs failed to realize, Akihiko Odaki, 2024/02/20
[PATCH v6 07/15] pcie_sriov: Do not manually unrealize, Akihiko Odaki, 2024/02/20
[PATCH v6 11/15] pcie_sriov: Register VFs after migration, Akihiko Odaki, 2024/02/20
[PATCH v6 10/15] pcie_sriov: Remove num_vfs from PCIESriovPF, Akihiko Odaki, 2024/02/20
[PATCH v6 12/15] hw/pci: Use -1 as a default value for rombar, Akihiko Odaki, 2024/02/20