[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH v4 07/10] hw/mem/cxl_type3: Add DC extent list representative
From: |
fan |
Subject: |
Re: [PATCH v4 07/10] hw/mem/cxl_type3: Add DC extent list representative and get DC extent list mailbox support |
Date: |
Fri, 23 Feb 2024 08:56:09 -0800 |
On Fri, Feb 23, 2024 at 04:16:53PM +0900, Wonjae Lee wrote:
> On 2024-02-22 오전 3:16, nifan.cxl@gmail.com wrote:
> > From: Fan Ni <fan.ni@samsung.com>
> >
> > Add dynamic capacity extent list representative to the definition of
> > CXLType3Dev and add get DC extent list mailbox command per
> > CXL.spec.3.1:.8.2.9.9.9.2.
> >
> > Signed-off-by: Fan Ni <fan.ni@samsung.com>
> > ---
> > hw/cxl/cxl-mailbox-utils.c | 71 +++++++++++++++++++++++++++++++++++++
> > hw/mem/cxl_type3.c | 1 +
> > include/hw/cxl/cxl_device.h | 23 ++++++++++++
> > 3 files changed, 95 insertions(+)
> >
> > diff --git a/hw/cxl/cxl-mailbox-utils.c b/hw/cxl/cxl-mailbox-utils.c
> > index f95e417683..dae7fe00ed 100644
> > --- a/hw/cxl/cxl-mailbox-utils.c
> > +++ b/hw/cxl/cxl-mailbox-utils.c
> > @@ -83,6 +83,7 @@ enum {
> > #define CLEAR_POISON 0x2
> > DCD_CONFIG = 0x48,
> > #define GET_DC_CONFIG 0x0
> > + #define GET_DYN_CAP_EXT_LIST 0x1
> > PHYSICAL_SWITCH = 0x51,
> > #define IDENTIFY_SWITCH_DEVICE 0x0
> > #define GET_PHYSICAL_PORT_STATE 0x1
> > @@ -1344,6 +1345,73 @@ static CXLRetCode cmd_dcd_get_dyn_cap_config(const
> > struct cxl_cmd *cmd,
> > return CXL_MBOX_SUCCESS;
> > }
> > +/*
> > + * CXL r3.1 section 8.2.9.9.9.2:
> > + * Get Dynamic Capacity Extent List (Opcode 4801h)
> > + */
> > +static CXLRetCode cmd_dcd_get_dyn_cap_ext_list(const struct cxl_cmd *cmd,
> > + uint8_t *payload_in,
> > + size_t len_in,
> > + uint8_t *payload_out,
> > + size_t *len_out,
> > + CXLCCI *cci)
> > +{
> > + CXLType3Dev *ct3d = CXL_TYPE3(cci->d);
> > + struct get_dyn_cap_ext_list_in_pl {
> > + uint32_t extent_cnt;
> > + uint32_t start_extent_id;
> > + } QEMU_PACKED;
> > +
> > + struct get_dyn_cap_ext_list_out_pl {
> > + uint32_t count;
> > + uint32_t total_extents;
> > + uint32_t generation_num;
> > + uint8_t rsvd[4];
> > + CXLDCExtentRaw records[];
> > + } QEMU_PACKED;
> > +
> > + struct get_dyn_cap_ext_list_in_pl *in = (void *)payload_in;
> > + struct get_dyn_cap_ext_list_out_pl *out = (void *)payload_out;
> > + uint16_t record_count = 0, i = 0, record_done = 0;
> > + CXLDCExtentList *extent_list = &ct3d->dc.extents;
> > + CXLDCExtent *ent;
> > + uint16_t out_pl_len;
> > + uint32_t start_extent_id = in->start_extent_id;
> > +
> > + if (start_extent_id > ct3d->dc.total_extent_count) {
>
> Hello,
>
> Shouldn't it be >= rather than >?
>
> (I accidentally replied to v3 with the same comment above, so please ignore
> that.)
The spec says "Greater than", so I will keep it as it is until there is
more clarification about this. When start_extent_id ==
total_extent_count, return 0 extents.
Fan
>
> Thanks,
> Wonjae
>
- Re: [PATCH v4 02/10] hw/cxl/cxl-mailbox-utils: Add dynamic capacity region representative and mailbox command support, (continued)
- [PATCH v4 04/10] hw/mem/cxl_type3: Add support to create DC regions to type3 memory devices, nifan . cxl, 2024/02/21
- [PATCH v4 01/10] hw/cxl/cxl-mailbox-utils: Add dc_event_log_size field to output payload of identify memory device command, nifan . cxl, 2024/02/21
- [PATCH v4 03/10] include/hw/cxl/cxl_device: Rename mem_size as static_mem_size for type3 memory devices, nifan . cxl, 2024/02/21
- [PATCH v4 05/10] hw/mem/cxl-type3: Refactor ct3_build_cdat_entries_for_mr to take mr size insead of mr as argument, nifan . cxl, 2024/02/21
- [PATCH v4 06/10] hw/mem/cxl_type3: Add host backend and address space handling for DC regions, nifan . cxl, 2024/02/21
- [PATCH v4 07/10] hw/mem/cxl_type3: Add DC extent list representative and get DC extent list mailbox support, nifan . cxl, 2024/02/21
- [PATCH v4 10/10] hw/mem/cxl_type3: Add dpa range validation for accesses to DC regions, nifan . cxl, 2024/02/21
- [PATCH v4 09/10] hw/cxl/events: Add qmp interfaces to add/release dynamic capacity extents, nifan . cxl, 2024/02/21
- [PATCH v4 08/10] hw/cxl/cxl-mailbox-utils: Add mailbox commands to support add/release dynamic capacity response, nifan . cxl, 2024/02/21