[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 11/19] hw/sd/sdcard: Trace update of block count (CMD23)
From: |
Philippe Mathieu-Daudé |
Subject: |
[PULL 11/19] hw/sd/sdcard: Trace update of block count (CMD23) |
Date: |
Mon, 24 Jun 2024 15:14:32 +0200 |
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
Reviewed-by: Cédric Le Goater <clg@redhat.com>
Tested-by: Cédric Le Goater <clg@redhat.com>
Message-Id: <20240621080554.18986-12-philmd@linaro.org>
---
hw/sd/sd.c | 1 +
hw/sd/trace-events | 3 ++-
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/hw/sd/sd.c b/hw/sd/sd.c
index 4afb6988c7..44225bae9b 100644
--- a/hw/sd/sd.c
+++ b/hw/sd/sd.c
@@ -1090,6 +1090,7 @@ static sd_rsp_type_t sd_cmd_SET_BLOCK_COUNT(SDState *sd,
SDRequest req)
}
sd->multi_blk_cnt = req.arg;
+ trace_sdcard_set_block_count(sd->multi_blk_cnt);
return sd_r1;
}
diff --git a/hw/sd/trace-events b/hw/sd/trace-events
index 94a00557b2..724365efc3 100644
--- a/hw/sd/trace-events
+++ b/hw/sd/trace-events
@@ -43,7 +43,8 @@ sdcard_response(const char *rspdesc, int rsplen) "%s (sz:%d)"
sdcard_powerup(void) ""
sdcard_inquiry_cmd41(void) ""
sdcard_reset(void) ""
-sdcard_set_blocklen(uint16_t length) "0x%03x"
+sdcard_set_blocklen(uint16_t length) "block len 0x%03x"
+sdcard_set_block_count(uint32_t cnt) "block cnt 0x%"PRIx32
sdcard_inserted(bool readonly) "read_only: %u"
sdcard_ejected(void) ""
sdcard_erase(uint32_t first, uint32_t last) "addr first 0x%" PRIx32" last 0x%"
PRIx32
--
2.41.0
- [PULL 01/19] bswap: Add st24_be_p() to store 24 bits in big-endian order, (continued)
- [PULL 01/19] bswap: Add st24_be_p() to store 24 bits in big-endian order, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 02/19] hw/sd/sdcard: Avoid OOB in sd_read_byte() during unexpected CMD switch, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 03/19] hw/sd/sdcard: Correct code indentation, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 04/19] hw/sd/sdcard: Rewrite sd_cmd_ALL_SEND_CID using switch case (CMD2), Philippe Mathieu-Daudé, 2024/06/24
- [PULL 05/19] hw/sd/sdcard: Fix typo in SEND_OP_COND command name, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 06/19] hw/sd/sdcard: Use HWBLOCK_SHIFT definition instead of magic values, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 07/19] hw/sd/sdcard: Use registerfield CSR::CURRENT_STATE definition, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 08/19] hw/sd/sdcard: Use Load/Store API to fill some CID/CSD registers, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 09/19] hw/sd/sdcard: Remove ACMD6 handler for SPI mode, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 10/19] hw/sd/sdcard: Remove explicit entries for illegal commands, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 11/19] hw/sd/sdcard: Trace update of block count (CMD23),
Philippe Mathieu-Daudé <=
- [PULL 12/19] hw/sd/sdcard: Have cmd_valid_while_locked() return a boolean value, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 13/19] hw/sd/sdcard: Factor sd_req_get_rca() method out, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 14/19] hw/sd/sdcard: Only call sd_req_get_rca() where RCA is used, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 15/19] hw/sd/sdcard: Factor sd_req_get_address() method out, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 16/19] hw/sd/sdcard: Only call sd_req_get_address() where address is used, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 17/19] hw/sd/sdcard: Add sd_invalid_mode_for_cmd to report invalid mode switch, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 18/19] hw/sd/sdcard: Inline BLK_READ_BLOCK / BLK_WRITE_BLOCK macros, Philippe Mathieu-Daudé, 2024/06/24
- [PULL 19/19] hw/sd/sdcard: Add comments around registers and commands, Philippe Mathieu-Daudé, 2024/06/24
- Re: [PULL 00/19] SD/MMC patches for 2024-06-24, Richard Henderson, 2024/06/25