[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PULL 07/65] hw/pci: Add a busnr property to pci_props and use for acpi/
From: |
Michael S. Tsirkin |
Subject: |
[PULL 07/65] hw/pci: Add a busnr property to pci_props and use for acpi/gi |
Date: |
Mon, 4 Nov 2024 16:05:53 -0500 |
From: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Using a property allows us to hide the internal details of the PCI device
from the code to build a SRAT Generic Initiator Affinity Structure with
PCI Device Handle.
Suggested-by: Igor Mammedov <imammedo@redhat.com>
Reviewed-by: Igor Mammedov <imammedo@redhat.com>
Signed-off-by: Jonathan Cameron <Jonathan.Cameron@huawei.com>
Message-Id: <20240916171017.1841767-6-Jonathan.Cameron@huawei.com>
Reviewed-by: Michael S. Tsirkin <mst@redhat.com>
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
---
hw/acpi/acpi_generic_initiator.c | 14 +++++++++-----
hw/pci/pci.c | 14 ++++++++++++++
2 files changed, 23 insertions(+), 5 deletions(-)
diff --git a/hw/acpi/acpi_generic_initiator.c b/hw/acpi/acpi_generic_initiator.c
index 73bafaaaea..365feb527f 100644
--- a/hw/acpi/acpi_generic_initiator.c
+++ b/hw/acpi/acpi_generic_initiator.c
@@ -9,6 +9,7 @@
#include "hw/boards.h"
#include "hw/pci/pci_device.h"
#include "qemu/error-report.h"
+#include "qapi/error.h"
typedef struct AcpiGenericInitiatorClass {
ObjectClass parent_class;
@@ -79,7 +80,8 @@ static int build_acpi_generic_initiator(Object *obj, void
*opaque)
MachineState *ms = MACHINE(qdev_get_machine());
AcpiGenericInitiator *gi;
GArray *table_data = opaque;
- PCIDevice *pci_dev;
+ int32_t devfn;
+ uint8_t bus;
Object *o;
if (!object_dynamic_cast(obj, TYPE_ACPI_GENERIC_INITIATOR)) {
@@ -100,10 +102,12 @@ static int build_acpi_generic_initiator(Object *obj, void
*opaque)
exit(1);
}
- pci_dev = PCI_DEVICE(o);
- build_srat_pci_generic_initiator(table_data, gi->node, 0,
- pci_bus_num(pci_get_bus(pci_dev)),
- pci_dev->devfn);
+ bus = object_property_get_uint(o, "busnr", &error_fatal);
+ devfn = object_property_get_int(o, "addr", &error_fatal);
+ /* devfn is constrained in PCI to be 8 bit but storage is an int32_t */
+ assert(devfn >= 0 && devfn < PCI_DEVFN_MAX);
+
+ build_srat_pci_generic_initiator(table_data, gi->node, 0, bus, devfn);
return 0;
}
diff --git a/hw/pci/pci.c b/hw/pci/pci.c
index 87da35ca9b..0b6bdaa0d7 100644
--- a/hw/pci/pci.c
+++ b/hw/pci/pci.c
@@ -67,6 +67,19 @@ static char *pcibus_get_fw_dev_path(DeviceState *dev);
static void pcibus_reset_hold(Object *obj, ResetType type);
static bool pcie_has_upstream_port(PCIDevice *dev);
+static void prop_pci_busnr_get(Object *obj, Visitor *v, const char *name,
+ void *opaque, Error **errp)
+{
+ uint8_t busnr = pci_dev_bus_num(PCI_DEVICE(obj));
+
+ visit_type_uint8(v, name, &busnr, errp);
+}
+
+static const PropertyInfo prop_pci_busnr = {
+ .name = "busnr",
+ .get = prop_pci_busnr_get,
+};
+
static Property pci_props[] = {
DEFINE_PROP_PCI_DEVFN("addr", PCIDevice, devfn, -1),
DEFINE_PROP_STRING("romfile", PCIDevice, romfile),
@@ -87,6 +100,7 @@ static Property pci_props[] = {
QEMU_PCIE_ARI_NEXTFN_1_BITNR, false),
DEFINE_PROP_SIZE32("x-max-bounce-buffer-size", PCIDevice,
max_bounce_buffer_size, DEFAULT_MAX_BOUNCE_BUFFER_SIZE),
+ { .name = "busnr", .info = &prop_pci_busnr },
DEFINE_PROP_END_OF_LIST()
};
--
MST
- [PULL 00/65] virtio,pc,pci: features, fixes, cleanups, Michael S. Tsirkin, 2024/11/04
- [PULL 01/65] softmmu: Expand comments describing max_bounce_buffer_size, Michael S. Tsirkin, 2024/11/04
- [PULL 02/65] docs: fix vhost-user protocol doc, Michael S. Tsirkin, 2024/11/04
- [PULL 03/65] hw/acpi: Fix ordering of BDF in Generic Initiator PCI Device Handle., Michael S. Tsirkin, 2024/11/04
- [PULL 04/65] hw/acpi/GI: Fix trivial parameter alignment issue., Michael S. Tsirkin, 2024/11/04
- [PULL 05/65] hw/acpi: Move AML building code for Generic Initiators to aml_build.c, Michael S. Tsirkin, 2024/11/04
- [PULL 06/65] hw/acpi: Rename build_all_acpi_generic_initiators() to build_acpi_generic_initiator(), Michael S. Tsirkin, 2024/11/04
- [PULL 07/65] hw/pci: Add a busnr property to pci_props and use for acpi/gi,
Michael S. Tsirkin <=
- [PULL 08/65] acpi/pci: Move Generic Initiator object handling into acpi/pci.*, Michael S. Tsirkin, 2024/11/04
- [PULL 09/65] hw/pci-bridge: Add acpi_uid property to TYPE_PXB_BUS, Michael S. Tsirkin, 2024/11/04
- [PULL 10/65] hw/i386/acpi: Use TYPE_PXB_BUS property acpi_uid for DSDT, Michael S. Tsirkin, 2024/11/04
- [PULL 11/65] hw/pci-host/gpex-acpi: Use acpi_uid property., Michael S. Tsirkin, 2024/11/04
- [PULL 12/65] hw/acpi: Generic Port Affinity Structure support, Michael S. Tsirkin, 2024/11/04
- [PULL 13/65] hw/acpi: Make storage of node id uint32_t to reduce fragility, Michael S. Tsirkin, 2024/11/04
- [PULL 14/65] hw/acpi: Generic Initiator - add missing object class property descriptions., Michael S. Tsirkin, 2024/11/04
- [PULL 15/65] hw/pci-bridge/cxl_root_port: Provide x-speed and x-width properties., Michael S. Tsirkin, 2024/11/04