These are some small clean ups for target/ppc/excp_helper.c trying to
make this code a bit simpler. No functional change is intended.
v2: Patch 3 changes according to review, added tags
v3: Address more review comments: don't change cpu_interrupt_exittb()
parameter, add back lev, add scv patch from Nick + add some more
patches to clean up #ifdefs
Regards,
BALATON Zoltan
BALATON Zoltan (13):
target/ppc: Remove some superfluous parentheses
target/ppc: Remove unneeded parameter from powerpc_reset_wakeup()
target/ppc: Move common check in exception handlers to a function
target/ppc: Use env_cpu for cpu_abort in excp_helper
target/ppc: Remove some more local CPUState variables only used once
target/ppc: Readability improvements in exception handlers
target/ppd: Remove unused define
target/ppc: Fix gen_sc to use correct nip
target/ppc: Simplify syscall exception handlers
target/ppc: Get CPUState in one step
target/ppc: Clean up ifdefs in excp_helper.c, part 1
target/ppc: Clean up ifdefs in excp_helper.c, part 2
target/ppc: Clean up ifdefs in excp_helper.c, part 3
Nicholas Piggin (1):
target/ppc: Move patching nip from exception handler to helper_scv
target/ppc/cpu.h | 1 +
target/ppc/excp_helper.c | 570 ++++++++++++---------------------------
target/ppc/translate.c | 15 +-
3 files changed, 178 insertions(+), 408 deletions(-)