[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[qemu-s390x] [PATCH v4] s390x: remove direct reference to mem_path globa
From: |
Igor Mammedov |
Subject: |
[qemu-s390x] [PATCH v4] s390x: remove direct reference to mem_path global from s390x code |
Date: |
Wed, 30 Jan 2019 08:55:06 +0100 |
I plan to deprecate -mem-path option and replace it with memory-backend,
for that it's necessary to get rid of mem_path global variable.
Do it for s390x case, replacing it with alternative way to enable
1Mb hugepages capability.
Todo that replace qemu_mempath_getpagesize() with qemu_getrampagesize()
which also checks for -mem-path provided RAM.
Signed-off-by: Igor Mammedov <address@hidden>
---
v4:
* fix typos in commit message
* add include "exec/ram_addr.h" to make sure it compiles on ppc host
v2:
* s/qemu_mempath_getpagesize/qemu_getrampagesiz/ and drop the rest of changes
David Hildenbrand <address@hidden>
---
target/s390x/kvm.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/target/s390x/kvm.c b/target/s390x/kvm.c
index 2ebf26a..8613e19 100644
--- a/target/s390x/kvm.c
+++ b/target/s390x/kvm.c
@@ -42,6 +42,7 @@
#include "hw/hw.h"
#include "sysemu/device_tree.h"
#include "exec/gdbstub.h"
+#include "exec/ram_addr.h"
#include "trace.h"
#include "hw/s390x/s390-pci-inst.h"
#include "hw/s390x/s390-pci-bus.h"
@@ -287,7 +288,7 @@ void kvm_s390_crypto_reset(void)
static int kvm_s390_configure_mempath_backing(KVMState *s)
{
- size_t path_psize = qemu_mempath_getpagesize(mem_path);
+ size_t path_psize = qemu_getrampagesize();
if (path_psize == 4 * KiB) {
return 0;
@@ -319,7 +320,7 @@ int kvm_arch_init(MachineState *ms, KVMState *s)
{
MachineClass *mc = MACHINE_GET_CLASS(ms);
- if (mem_path && kvm_s390_configure_mempath_backing(s)) {
+ if (kvm_s390_configure_mempath_backing(s)) {
return -EINVAL;
}
--
2.7.4
- [qemu-s390x] [PATCH v4] s390x: remove direct reference to mem_path global from s390x code,
Igor Mammedov <=