[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [qemu-s390x] [PATCH v2 3/7] s390x/tcg: Clarify terminology in vec_re
From: |
David Hildenbrand |
Subject: |
Re: [qemu-s390x] [PATCH v2 3/7] s390x/tcg: Clarify terminology in vec_reg_offset() |
Date: |
Mon, 25 Feb 2019 23:28:27 +0100 |
User-agent: |
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.4.0 |
On 25.02.19 21:03, David Hildenbrand wrote:
> We will use s390x speak "Element Size" (es) for MO_8 == 0, MO_16 == 1
> ... Simple rename of variables.
>
> Reviewed-by: Thomas Huth <address@hidden>
> Reviewed-by: Richard Henderson <address@hidden>
> Signed-off-by: David Hildenbrand <address@hidden>
> ---
> target/s390x/translate.c | 11 ++++++-----
> 1 file changed, 6 insertions(+), 5 deletions(-)
>
> diff --git a/target/s390x/translate.c b/target/s390x/translate.c
> index c646e50eb3..5e3955e4d7 100644
> --- a/target/s390x/translate.c
> +++ b/target/s390x/translate.c
> @@ -145,10 +145,11 @@ void s390x_translate_init(void)
> }
> }
>
> -static inline int vec_reg_offset(uint8_t reg, uint8_t enr, TCGMemOp size)
> +static inline int vec_reg_offset(uint8_t reg, uint8_t enr, TCGMemOp es)
> {
> - const uint8_t es = 1 << size;
> - int offs = enr * es;
> + /* Convert element size (es) - e.g. MO_U8 - to bytes */
s/MO_U8/MO_8/ :(
Conny, I assume you can fix that up in case there are no other comments.
Thanks!
> + const uint8_t bytes = 1 << es;
> + int offs = enr * bytes;
>
> g_assert(reg < 32);
> /*
> @@ -173,9 +174,9 @@ static inline int vec_reg_offset(uint8_t reg, uint8_t
> enr, TCGMemOp size)
> * the two 8 byte elements have to be loaded separately. Let's force all
> * 16 byte operations to handle it in a special way.
> */
> - g_assert(size <= MO_64);
> + g_assert(es <= MO_64);
> #ifndef HOST_WORDS_BIGENDIAN
> - offs ^= (8 - es);
> + offs ^= (8 - bytes);
> #endif
> return offs + offsetof(CPUS390XState, vregs[reg][0].d);
> }
>
--
Thanks,
David / dhildenb
- [qemu-s390x] [PATCH v2 0/7] s390x/tcg: Cleanups and refactorings for vector instructions, David Hildenbrand, 2019/02/25
- [qemu-s390x] [PATCH v2 1/7] s390x/tcg: RXE has an optional M3 field, David Hildenbrand, 2019/02/25
- [qemu-s390x] [PATCH v2 4/7] s390x/tcg: Factor out vec_full_reg_offset(), David Hildenbrand, 2019/02/25
- [qemu-s390x] [PATCH v2 5/7] s390x/tcg: Factor out gen_addi_and_wrap_i64() from get_address(), David Hildenbrand, 2019/02/25
- [qemu-s390x] [PATCH v2 6/7] s390x/tcg: Implement LOAD LENGTHENED short HFP to long HFP, David Hildenbrand, 2019/02/25
- [qemu-s390x] [PATCH v2 2/7] s390x/tcg: Simplify disassembler operands initialization, David Hildenbrand, 2019/02/25
- [qemu-s390x] [PATCH v2 7/7] s390x/tcg: Implement LOAD COUNT TO BLOCK BOUNDARY, David Hildenbrand, 2019/02/25
- Re: [qemu-s390x] [PATCH v2 0/7] s390x/tcg: Cleanups and refactorings for vector instructions, David Hildenbrand, 2019/02/25
- [qemu-s390x] [PATCH v2 3/7] s390x/tcg: Clarify terminology in vec_reg_offset(), David Hildenbrand, 2019/02/25
- Re: [qemu-s390x] [PATCH v2 3/7] s390x/tcg: Clarify terminology in vec_reg_offset(),
David Hildenbrand <=
- Re: [qemu-s390x] [PATCH v2 0/7] s390x/tcg: Cleanups and refactorings for vector instructions, Cornelia Huck, 2019/02/26