[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[PATCH 2/5] hw/core/cpu: Rename cpu_class_init() to include 'common'
From: |
Philippe Mathieu-Daudé |
Subject: |
[PATCH 2/5] hw/core/cpu: Rename cpu_class_init() to include 'common' |
Date: |
Thu, 11 Jan 2024 13:02:18 +0100 |
cpu_class_init() is common, so rename it as cpu_common_class_init()
to ease navigating the code.
Signed-off-by: Philippe Mathieu-Daudé <philmd@linaro.org>
---
hw/core/cpu-common.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/hw/core/cpu-common.c b/hw/core/cpu-common.c
index 3ccfe882e2..67db07741d 100644
--- a/hw/core/cpu-common.c
+++ b/hw/core/cpu-common.c
@@ -273,7 +273,7 @@ static int64_t cpu_common_get_arch_id(CPUState *cpu)
return cpu->cpu_index;
}
-static void cpu_class_init(ObjectClass *klass, void *data)
+static void cpu_common_class_init(ObjectClass *klass, void *data)
{
DeviceClass *dc = DEVICE_CLASS(klass);
ResettableClass *rc = RESETTABLE_CLASS(klass);
@@ -304,7 +304,7 @@ static const TypeInfo cpu_type_info = {
.instance_finalize = cpu_common_finalize,
.abstract = true,
.class_size = sizeof(CPUClass),
- .class_init = cpu_class_init,
+ .class_init = cpu_common_class_init,
};
static void cpu_register_types(void)
--
2.41.0
- [PATCH 0/5] misc: Trivial code rename cleanup, Philippe Mathieu-Daudé, 2024/01/11
- [PATCH 3/5] hw/s390x: Rename cpu_class_init() to include 'sclp', Philippe Mathieu-Daudé, 2024/01/11
- [PATCH 1/5] accel: Rename accel_init_ops_interfaces() to include 'system', Philippe Mathieu-Daudé, 2024/01/11
- [PATCH 2/5] hw/core/cpu: Rename cpu_class_init() to include 'common',
Philippe Mathieu-Daudé <=
- [PATCH 4/5] target/i386: Rename tcg_cpu_FOO() to include 'x86', Philippe Mathieu-Daudé, 2024/01/11
- [PATCH 5/5] target/riscv: Rename tcg_cpu_FOO() to include 'riscv', Philippe Mathieu-Daudé, 2024/01/11
- Re: [PATCH 0/5] misc: Trivial code rename cleanup, Philippe Mathieu-Daudé, 2024/01/17