[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Qemu-trivial] [PATCH] memory: Rename readable flag to romd_mode

From: Paolo Bonzini
Subject: Re: [Qemu-trivial] [PATCH] memory: Rename readable flag to romd_mode
Date: Mon, 06 May 2013 18:32:45 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130311 Thunderbird/17.0.4

Il 06/05/2013 18:12, Jan Kiszka ha scritto:
> "Readable" is a very unfortunate name for this flag because even a
> rom_device region will always be readable from the guest POV. What
> differs is the mapping, just like the comments had to explain already.
> Also, readable could currently be understood as being a generic region
> flag, but it only applies to rom_device regions.
> So name the flag and the function to modify it after the original term
> "ROMD" which could also be interpreted as "ROM direct", i.e. ROM mode
> with direct access. In any case, the scope if the flag is clearer now.
> Signed-off-by: Jan Kiszka <address@hidden>
> ---
> Depends on "memory: Replace open-coded memory_region_is_romd", but I
> don't think this patch is "trivial" as well, though it is just renaming
> things. Just in case, I'm CCing the trivial list as well.
> Paolo, or would you open a memory branch so that related stuff can flow
> through one queue?

I think this is more trivial than the other actually.  :)  (For code
changes, I think trivial roughly means "if it compiles fine, it won't
break anything").

For now I applied both patches to my iommu branch.  I'll test it a bit
more tomorrow and then post the IOMMU patches for review.  We should
merge them and the subpage reorg soon in 1.6, since it is (together with
ref/unref) the main serialization point for all the work on BQL-less

BTW, a "trivial" patch would be one that actually defines the term "BQL"
somewhere in the code. :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]