[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[screen-devel] GNU screen misbehavior on Solaris 10

From: a b
Subject: [screen-devel] GNU screen misbehavior on Solaris 10
Date: Thu, 16 Nov 2023 12:24:57 +0000


I would like to report a bug which I have been unable to trace and / or debug 

When I do the following in tcsh, "Hello." isn't echoed to stdout and sending an 
end of file marker exits cat(1), as expected:

% cat > /dev/null

but if I do the same inside of GNU screen (version 4.09.1 20-Aug-23, or any 
other version), then the following happens:

% cat > /dev/null

..."Hello." is echoed to stdout when I press [RETURN], and ^D is printed as a 
literal caret followed by an uppercase D instead of being interpreted as an end 
of file marker.

This behavior is consistent:

- on Solaris 10 i86pc;
- on Solaris 10 sparc;
- in any shell;
- irrespective of which version of screen I've tried to compile and run;
- irrespective of compiler used (tried with Sun Studio 12.6 and GCC 9.5.0);
- irrespective of whether screen is linked with /lib/64/ (AT&T 
curses) or my own version of

stty(1) settings have no effect.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]