[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[W3-dev] Re: Compiling for CarbonEmacs on Mac OS X Tiger

From: Chry Cheng
Subject: [W3-dev] Re: Compiling for CarbonEmacs on Mac OS X Tiger
Date: Sun, 28 Sep 2008 14:09:00 +0800
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.2 (darwin)

"Christian Cheng" <address@hidden> writes:

> Trying to get W3 working with CarbonEmacs in Tiger.  First, I put the path to 
> the CarbonEmacs emacs executable up front in my $PATH env var.  Then, I ran 
> configure successfully using./configure 
> --with-lispdir=&#39;${prefix}&#39;/site-lisp 
> --with-gnus=&#39;${prefix}&#39;/lisp/gnus

Tried again with source pulled fresh from CVS.  Configured with:

./configure --with-emacs=/Applications/Emacs.app/Contents/MacOS/Emacs 

> Here&#39;s the output:creating cache ./config.cachechecking for a BSD 
> compatible install... /usr/bin/install -cchecking for texi2html... texi2html
> checking for xemacs... emacschecking for makeinfo... makeinfochecking for 
> install-info... install-infochecking if emacs is really XEmacs... nochecking 
> prefix for your Emacs... /Applications/Emacs.app/Contents
> checking where .elc files should go... ${prefix}/site-lispchecking for emacs 
> version... 22.2checking for acceptable custom library... 
> /Applications/Emacs.app/Contents/Resources/lisp/checking for recent gnus 
> version... ${prefix}/lisp/gnus
> checking how to rebuild custom autoloads... $(EMACS) $(BATCHFLAGS) $(DEPS) -f 
> emacs-batch-build-custom-load $(srcdir)creating ./config.statuscreating 
> Makefilecreating etc/Makefile
> creating texi/Makefilecreating lisp/Makefilecreating lisp/w3-cfg.el 
> Sucessfully configured Emacs/W3Using custom package installed in: 
> /Applications/Emacs.app/Contents/Resources/lisp/
> Emacs/W3 will be compiled with: emacs To finish building Emacs/W3 type 
> &#39;make&#39; now.To install Emacs/W3 type &#39;make install&#39;.To create 
> autoloads in &#39;/Users/xxx/.emacs&#39; type &#39;make dotemacs&#39;
> So, I figured that went well enough so I went ahead with make:cd lisp && make 
> w3GNUSDIR=/Applications/Emacs.app/Contents/lisp/gnus 
> WIDGETDIR=/Applications/Emacs.app/Contents/Resources/lisp/ W3SRCDIR=. emacs 
> -batch -q -no-site-file -l ./docomp.el -l ./url-vars.el -l ./w3-vars.el -f 
> batch-byte-compile mule-sysdp.el
> Loading 
> /Applications/Emacs.app/Contents/Resources/site-lisp/extra-autoloads.el 
> (source)...Loading 
> /Applications/Emacs.app/Contents/Resources/site-lisp/haskell-mode/haskell-site-file.el
>  (source)...
> !! File w3-sysdp uses old-style backquotes !!!! File font uses old-style 
> backquotes !!!! File css uses old-style backquotes !!!! File url-vars uses 
> old-style backquotes !!!! File url-parse uses old-style backquotes !!
> !! File w3-cus uses old-style backquotes !!!! File w3-widget uses old-style 
> backquotes !!!! File w3-imap uses old-style backquotes !!!! File w3-display 
> uses old-style backquotes !!
> !! File w3-parse uses old-style backquotes !!Cannot open load file: 
> w3-e22make[1]: *** [mule-sysdp.elc] Error 255make: *** [w3] Error 2Any ideas 
> anyone?  Is this related to http://bugs.gentoo.org/show_bug.cgi?i?

Finally got it to compile!  However, invoking with M-x gnus gives the ff. error:

Wrong type argument: arrayp, nil

Any ideas anyone?  Pulled up 
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=110778 in Google but I'm not 
sure this fix is applicable to Carbon Emacs.  The backtrace (username masked 
out) follows:

Debugger entered--Lisp error: (wrong-type-argument arrayp nil) 
  css-expand-length("+12pt" t) 
  css-expand-value(height "+12pt") 
  css-parse-args(238 257) 
nil nil) 

> Some version info:sw_vers gives:ProductName:    Mac OS XProductVersion: 
> 10.4.11BuildVersion:   8S165
> Then, M-x version gives:GNU Emacs 22.2.1 (powerpc-apple-darwin.8.11.0, Carbon 
> Version 1.6.0) of 2008-04-05 on http://g5.tokyo.stp.isas.jaxa.jpn
> _______________________________________________
> W3-dev mailing list
> address@hidden
> http://lists.gnu.org/mailman/listinfo/w3-dev

reply via email to

[Prev in Thread] Current Thread [Next in Thread]