[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[AUCTeX-devel] Re: re^2: Succesful AUCTeX installation for MS Win XP

From: David Kastrup
Subject: [AUCTeX-devel] Re: re^2: Succesful AUCTeX installation for MS Win XP
Date: Wed, 08 Jun 2005 14:51:14 +0200
User-agent: Gnus/5.11 (Gnus v5.11) Emacs/22.0.50 (gnu/linux)

[I just noticed that I sent this just in private, but it is definitely
of general interest to other developers since it concerns wordings and
similar in our manual, which we will have to amend.

So another mail, this time copying the list]

Grzegorz <address@hidden> writes:

>> Well, so that the others may benefit from your praise, I am taking the
>> liberty of forwarding this to the developer list.
> Of course.
>> Can you remember or reproduce the exact way you called configure, 
> In the MinGW window I changed directory to the one where unzipped AUCTeX 
> files were, i.e.
> C:\Documents and Settings\grzegorz.murzynowski\Moje 
> dokumenty\emacsAUCTeX\auctex-11.55
>  I wrote
> ./configure --prefix=/C:/Documents\ and\ Settings/grzegorz.murzynowski/Moje 
> dokumenty/emacs --with-emacs=/C:/Documents\ and\ 
> Settings/grzegorz.murzynowski/Moje dokumenty/emacs/emacs-21.3/bin/emacs.exe 
> Maybe one or both paths without a slash before "C:", I'm not sure.

That would be important to know: /C: is _not_ a valid path for _any_
environment that I am aware of.

> Then I ran make in the same directory
> Then, according advice of my friend, in 
> C:\Documents and Settings\grzegorz.murzynowski\Moje 
> dokumenty\emacs\emacs-21.3\site-lisp
> I created a directory (folder) auctex,
> I copied there all files with .elc extension from 
> ...\emacsAUCTeX\auctex-11.55
> and tex-site.el to
> C:\Documents and Settings\grzegorz.murzynowski\Moje dokumenty\emacs
> which is Emacs' home directory, added the line
> (require 'tex-site "~/tex-site.el")
> in my .emacs file
> and I launched Emacs.

> Emacs in the minibuffer displayed prompt for password to
> address@hidden: or sth. like that, I understood it tried to
> connect via ftp.

Holy cow.  That is impressive.  And amusing.

> Then I replaced
> C:\Documents and Settings\grzegorz.murzynowski\Moje dokumenty\emacs
> with
> ~/ (tilde slash)
> in the lines wchich are now 44: 
> (defvar TeX-lisp-directory "~/emacs-21.3/site-lisp/auctex" 
> and 67:
> (defcustom TeX-auto-global "~/emacs-21.3/var/auctex"
> And then Auctex worked perfectly.

> I attach to this email the tex-site.el file with restored original
> paths. I'm almost sure it was with no slash at the beginning in
> defvar TeX-lisp-directory line.

The actual line is

(defcustom TeX-auto-global "/C:/Documents and 
Settings/grzegorz.murzynowski/Moje dokumenty/emacs /emacs-21.3/var/auctex")

and two things are noteworthy: one is the leading / and another is the
space after emacs.

Both are possible to enter manually if you are not careful.  The space
could probably entered by entering a path ending in \  when written on
a shell command line.  I realize that we have several examples in the
manual writing things like


and it would appear that this particular shorthand does not lend
itself well to explaining the syntax to Windows users (and would
probably explain the starting / you used).  Do you have any
suggestions about how we could amend this?

Anyway, if you could reproduce how you arrived at the faulty
tex-site.el (or generate an installation failing differently), it
would be appreciated.

David Kastrup, Kriemhildstr. 15, 44793 Bochum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]