[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

glibc 2.2 include/g++/streambuf.h

From: Adrian Dewhurst
Subject: glibc 2.2 include/g++/streambuf.h
Date: Fri, 29 Dec 2000 00:54:02 -0600 (CST)

I've been having problems compiling C++ programs since upgrading to glibc
2.2, I'm running linux 2.2.18 (though glibc was originally compiled with
2.2.16, I recompiled today with 2.2.18... no effect) and it appears that
/usr/include/g++/streambuf.h has some issues.

This happens with many c++ programs, and I was able to reduce it to a very
small portion of code to reproduce

glibc 2.2 was compiled with
./configure --prefix=/usr --sysconfdir=/etc --enable-add-ons=linuxthreads

I ran make then make install, overwriting 2.1

As for the errors:
vile:~/streamdie$ gcc streamdie.cpp -o streamdie
In file included from /usr/include/g++/iostream.h:31,
                 from /usr/include/g++/iostream:6,
                 from streamdie.cpp:1:
/usr/include/g++/streambuf.h: In method `struct streampos 
streambuf::pubseekoff(long long int, ios::seek_dir, int = 3)':
/usr/include/g++/streambuf.h:362: conversion from `__off64_t' to non-scalar 
type `streampos' requested
/usr/include/g++/streambuf.h: In method `struct streampos 
streambuf::pubseekpos(_G_fpos64_t, int = 3)':
/usr/include/g++/streambuf.h:364: `struct streampos' used where a `long long 
int' was expected
streamdie.cpp: At top level:
streamdie.cpp:2: parse error before `;'
vile:~/streamdie$ cat streamdie.cpp
#include <iostream>
using std;

int main(int argc, char **argv) {
        cout << "Success" << endl;
        return 0;

In attempting to determine the source of the issue, I tried changing
/usr/include/linux and /usr/include/asm to the 2.2.16 kernel includes, but
there was no effect.

Attempting to compile gcc results in a similar error inside its .cc files,
while I never had a problem with C++ programs in prior versions of glibc
or the linux kernel (the only two pieces of software relevant that have
been updated)

vile:~$ gcc -v
Reading specs from /usr/lib/gcc-lib/i686-pc-linux-gnu/2.95.2/specs
gcc version 2.95.2 19991024 (release)

I would appreciate any possible workarounds/feedback/even flames if I'm
doing something wrong or if it's actually a glibc problem. If required, I
can provide access to this system for someone to check with, though it is
connected via a modem so one would have to be patient :-)

Adrian "SailorFrag" Dewhurst, Server Administrator of Edge Network
address@hidden / address@hidden -=- ICQ: 1912951
Edge Network: 
Gaming with an Edge!
For-pay Internet distributed processing.

Version: 3.12
GU/CM/! d-(pu) s:- a--->? C++(++++)$ UBL++$ P+++ L+++
E--- W++ N-- o K? w-(--) O- M--(-) V-- PS PE(-) Y PGP(+)
t+ 5+++ X R+ tv(--) b++ DI-- D+ G++ e->+++++ h!(++) !r !y+ 
(Geek code from http://geekcode.sourceforge.net/)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]