[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PSPP-BUG: Cant compile latest stable version pspp-stable-200910XX

From: Leonard Evens
Subject: PSPP-BUG: Cant compile latest stable version pspp-stable-200910XX
Date: Thu, 29 Oct 2009 07:44:02 -0500

I downloaded pspp-stable-20091027 from http://pspp.benpfaff.org/~blp.   
I tried to compile it on a 64 bit HP Pavilion running Fedora 11 (64 bit
version).  It configured successfully, but compilation failed.  I then
downloaded the 1025 version, and the same thing happened.  I attach
below the output of configure and the output of make for that trial.
The error reported at the end of the latter file is

src/data/make-file.c:180: error: too few arguments to function
make[2]: *** [src/data/src_data_libdata_a-make-file.o] Error 1
make[2]: Leaving directory `/home/len/Download/pspp-stable-20091025'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/len/Download/pspp-stable-20091025'
make: *** [all] Error 2

I had previously managed to compile an earlier version of 7.2.  It did
require adding a whole bunch of packages, but eventually I got it to
configure properly and  then make succeeded, and I installed it.
Unfortunately, with  that version, psppire crashed whenever I tried to
do anything, e.g., when sorting the data.

Can anyone suggest what is going on?  Have I done something wrong?  If
not, can anyone suggest a version which I can compile?  Or do I just
keep working backwards until I find one I can compile.

Does 64 bits make any difference?  I have another machine running the 32
bit version of Fedora 11, but there I have the Fedora package 0.6.1
installed, and I don't want to have to deal with two versions on the
same computer.

Leonard Evens address@hidden
Professor Emeritus, Department of Mathematics, Northwestern University

Attachment: configure.out
Description: Text document

Attachment: make.out
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]