[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

PSPP-BUG: Problem with Default Directory

From: Javier Rodríguez
Subject: PSPP-BUG: Problem with Default Directory
Date: Tue, 9 Feb 2021 04:21:52 +0000 (UTC)


I guess there is a problem with the default directory for saving datasets that 
causes problems, specially on Windows (I'm using Windows 10, pspp 
1.4.1-g79ad47). I also tried in Ubuntu (20.10 pspp 1.4.0)  and the problem is 
the same.

What is the problem?

When I try to save by syntax (e.g. SAVE TRANSLATE) it is supposed that the 
outfile is saved at the same directory than the original file. Sometimes that 
works. But sometimes PSPP tries to save in the default directory. For some 
reason the default directory on Windows is system32 (as you see on the image). 
And as a result for that location, I get "permission denied" warning because 
system32 is a system directory. If I run PSPP as Admin I am able to save the 
outfile, but I have to go to system32 folder to recover it.

In Ubuntu the default directory for saving is the User directory, so even 
though the original dataset (sav) was located in a different directory, the 
output file is saved in the User directory but here there is not "permission 
denied" because is not a system directory.

Best regards,


PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]