[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: PSPP-BUG: Problem with Default Directory

From: Ben Pfaff
Subject: Re: PSPP-BUG: Problem with Default Directory
Date: Mon, 8 Feb 2021 20:40:40 -0800

Well, this is interesting. PSPP uses the current directory (the directory that was
current when it was invoked) as the place to save files. I guess that in Windows
that defaults to system32, and in Ubuntu I guess that defaults to the user's
home directory.

I don't know what SPSS does in such a case. Does anyone else?

On Mon, Feb 8, 2021 at 8:27 PM Javier Rodríguez via Bug-gnu-pspp <bug-gnu-pspp@gnu.org> wrote:

I guess there is a problem with the default directory for saving datasets that causes problems, specially on Windows (I'm using Windows 10, pspp 1.4.1-g79ad47). I also tried in Ubuntu (20.10 pspp 1.4.0)  and the problem is the same.

What is the problem?

When I try to save by syntax (e.g. SAVE TRANSLATE) it is supposed that the outfile is saved at the same directory than the original file. Sometimes that works. But sometimes PSPP tries to save in the default directory. For some reason the default directory on Windows is system32 (as you see on the image). And as a result for that location, I get "permission denied" warning because system32 is a system directory. If I run PSPP as Admin I am able to save the outfile, but I have to go to system32 folder to recover it.

In Ubuntu the default directory for saving is the User directory, so even though the original dataset (sav) was located in a different directory, the output file is saved in the User directory but here there is not "permission denied" because is not a system directory.

Best regards,

JavierImagen integrada

Bug-gnu-pspp mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]