[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: hello-2.11 fails multibyte-1 and atexit-1 on musl

From: Reuben Thomas
Subject: Re: hello-2.11 fails multibyte-1 and atexit-1 on musl
Date: Thu, 27 Jan 2022 22:08:57 +0000

On Wed, 26 Jan 2022 at 12:59, Sergei Trofimovich <slyich@gmail.com> wrote:

Thanks for the report!

> From what I understand at
> https://wiki.musl-libc.org/functional-differences-from-glibc.html#Character-sets-and-locale
> musl deliberately supports any char -> wchar_t (and back) conversion for
> any char in LC_CTYPE=C. And thus the multibyte-1 test will always fail
> there.

I also found this problem on macOS. I tried on my GNU/Linux system
using an ISO-8859 locale for the test, but the multibyte conversion
does not fail! (e.g. in en_GB.iso88591). I also tried with
ru_RU.KOI8-R, same result.

It seems then that it's not going to be possible in general to find a
locale that will fail. These results suggest that on some libc's,
conversion will always succeed.

Hence, I'm removing the test.

> Not sure why atexit-1 fails. It seems to rely on
> close_stdout_set_file_name() call in atexit(), but I don't see where in
> code it's registered to call.

Line 155 registers close_stdout. I can't see anything wrong with the
way this is done; I'd be very grateful if you could investigate


reply via email to

[Prev in Thread] Current Thread [Next in Thread]