[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [dev-serveez] build breaks

From: Martin Grabmueller
Subject: Re: [dev-serveez] build breaks
Date: Sat, 30 Jun 2001 08:48:21 +0200

> From: stefan <address@hidden>
> Date: Tue, 26 Jun 2001 17:19:32 +0200 (CEST)
> On Tue, 5 Jun 2001, Martin Grabmueller wrote:
> > What's going on here?  I just graded up to autoconf-2.50,
> > automake-1.4-p2 and libtool-1.4, so maybe that's the problem?
> This is because autoconf-2.50 is not able to handle AC_CHECK_FUNC()
> correctly within recursions. It's broken, I guess.

I just tried with older versions of the auto-tools, and now I run into
the following:

make[2]: Entering directory `/home/mgrabmue/cvs/serveez/test'
/bin/sh ../libtool --mode=link gcc  -g -O2  -o hash-test  hash-test.o test.o 
-L../src/libserveez -lserveez 
gcc -g -O2 -o .libs/hash-test hash-test.o test.o  
/home/mgrabmue/cvs/serveez/src/libserveez/.libs/ -Wl,--rpath 
/home/mgrabmue/cvs/serveez/src/libserveez/.libs/ undefined 
reference to `dlerror'
/home/mgrabmue/cvs/serveez/src/libserveez/.libs/ undefined 
reference to `dlclose'
/home/mgrabmue/cvs/serveez/src/libserveez/.libs/ undefined 
reference to `dlopen'
/home/mgrabmue/cvs/serveez/src/libserveez/.libs/ undefined 
reference to `dlsym'
collect2: ld returned 1 exit status
make[2]: *** [hash-test] Error 1
make[2]: Leaving directory `/home/mgrabmue/cvs/serveez/test'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/mgrabmue/cvs/serveez'
make: *** [all-recursive-am] Error 2

Mighty strange.  Any idea what is happening here?

I configured with


reply via email to

[Prev in Thread] Current Thread [Next in Thread]