[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [dev-serveez] build breaks

From: stefan
Subject: Re: [dev-serveez] build breaks
Date: Sat, 30 Jun 2001 15:26:02 +0200 (CEST)

On Sat, 30 Jun 2001, Martin Grabmueller wrote:

> I just tried with older versions of the auto-tools, and now I run into
> the following:
> make[2]: Entering directory `/home/mgrabmue/cvs/serveez/test'
> /bin/sh ../libtool --mode=link gcc  -g -O2  -o hash-test  hash-test.o test.o 
> -L../src/libserveez -lserveez 
> gcc -g -O2 -o .libs/hash-test hash-test.o test.o  
> -L/home/mgrabmue/cvs/serveez/src/libserveez 
> /home/mgrabmue/cvs/serveez/src/libserveez/.libs/ -Wl,--rpath 
> -Wl,/usr/local/lib
> /home/mgrabmue/cvs/serveez/src/libserveez/.libs/ undefined 
> reference to `dlerror'
> /home/mgrabmue/cvs/serveez/src/libserveez/.libs/ undefined 
> reference to `dlclose'
> /home/mgrabmue/cvs/serveez/src/libserveez/.libs/ undefined 
> reference to `dlopen'
> /home/mgrabmue/cvs/serveez/src/libserveez/.libs/ undefined 
> reference to `dlsym'
> collect2: ld returned 1 exit status
> make[2]: *** [hash-test] Error 1
> make[2]: Leaving directory `/home/mgrabmue/cvs/serveez/test'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/mgrabmue/cvs/serveez'
> make: *** [all-recursive-am] Error 2
> Mighty strange.  Any idea what is happening here?

Argh. It does not occur to my installation. Apparently the -ldl is
missing. Somehow my linker "knows" about itself linked
against and does not complain if it links some bin program

Maybe try once again:
 $ rm config.cache
 $ sh
 $ make


reply via email to

[Prev in Thread] Current Thread [Next in Thread]