[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Gluster-devel] xattr support

From: Hans K. Rosbach
Subject: Re: [Gluster-devel] xattr support
Date: Fri, 06 May 2011 16:53:41 +0200

On Fri, 2011-05-06 at 10:35 -0400, Jeff Darcy wrote:
> On 05/06/2011 10:31 AM, Hans K. Rosbach wrote:
> > I see what you mean. However this test gives the same results:
> > Ext4:
> > [root /]# setfattr -n user.testattr -v "foo" testfile
> > 
> > GlusterFS:
> > [root storage1]# setfattr -n user.testattr -v "foo" glusterfile
> > setfattr: glusterfile: Operation not supported
> > 
> > So, does GlusterFS not support xattrs or is my config somehow wrong?
> GlusterFS does support xattrs - I've worked extensively with this
> functionality myself - so it must be the config. Are you sure that the
> server-side bricks which make up your GlusterFS filesystem are on
> filesystems mounted with user_xattr?

Thank you, that was indeed the fault.

On the server, for some reason the rootfs does support user_xattr even
without it being specified in the fstab file (maybe a hardcoded default
for the root filesystem?
But the /storage1 filesystem that has an identical parameters in fstab
did not get user_xattr by default. (Both have only "noatime", not

I had thought that GlusterFS would not have worked at all without
user_xattr on the server side, so it did not even occur to me to check
the server side mount. A server log message about this would probably
have been nice.

I am happy to say that I now have no remaining issues with our
glusterfs setup whatsoever after 2 months of extensive testing.
The problems that did show up were quickly corrected in 3.1.3
and 3.1.4. We are now looking at going to production with the system.

  Hans K. Rosbach

reply via email to

[Prev in Thread] Current Thread [Next in Thread]