[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Gluster-devel] Failing to compile on FreeBSD 8.2

From: Damian Pound
Subject: [Gluster-devel] Failing to compile on FreeBSD 8.2
Date: Tue, 25 Oct 2011 11:01:20 -0500
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110922 Thunderbird/3.1.15

Initially I just did "./configure; make", but configure didn't enable the fuse client and make failed because of some operator thing. Then I found that FreeBSD uses a different make from GNU/Linux, so I installed gmake, still failed but seemed to have more promising errors. I decided to try compiling the last version of gluster that supported MacOSX, 2.0.2, that managed to compile, though I haven't tested it since it is 2 years old. I went to get gcc 4.6.0 since there were a lot of changes since 4.2.1, this made the compile of 2.0.2 and 2.0.9 enable fuse, but 3.1.7 and 3.2.4 still don't enable it. I tried --enable-fuse-client a few times, but that was either ignored or the configure failed.

So that was some of the stuff I did, heres some info about my machine and the configure/make of those 4 versions I tried
~Damian Pound

reply via email to

[Prev in Thread] Current Thread [Next in Thread]