[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Lemote: network interfaces down at startup

From: Federico Bruni
Subject: Re: [gNewSense-users] Lemote: network interfaces down at startup
Date: Mon, 10 May 2010 20:36:15 +0200

On Sun, 2010-05-09 at 19:20 +0200, Sam Geeraerts wrote:
> Federico Bruni schreef:
> > On Sun, 2010-05-09 at 14:11 +0200, Sam Geeraerts wrote:
> >> Try ln -s /etc/init.d/yeeloong-base /etc/rcS.d/S38yeeloong-base
> > 
> > Thanks, now it works perfect (I've tested just the wired connection
> but
> > I guess wireless will work as well).
> The yeeloong-base init only affects wireless. The interfaces file you 
> posted originally didn't include eth0, so it makes sense that you
> didn't 
> have a wired connection. I would be surprised if it works now because
> of 
> the change I suggested.

I tested the wireless and it works fine.
There is still one small problem:

When I boot, the system is not able to understand that eth0 is not
plugged, so it tries to connect through eth0 first. That's a waste of
time I'd like to avoid.
Then it tries wlan0, which works.

Can I fix it somehow?

This is my /etc/network/interfaces:

auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
auto eth0
iface eth0 inet dhcp

# WiFi
auto wlan0
iface wlan0 inet dhcp
wireless-essid NETGEAR
wireless-channel 11
wireless-mode managed
wpa-driver wext
wpa-conf /etc/wpa_supplicant.conf

reply via email to

[Prev in Thread] Current Thread [Next in Thread]