[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [gNewSense-users] Observations after reinstalling GNS on a Yeeloong

From: Sam Geeraerts
Subject: Re: [gNewSense-users] Observations after reinstalling GNS on a Yeeloong laptop
Date: Wed, 19 Jan 2011 22:59:46 +0100
User-agent: Thunderbird (X11/20100415)

samy boutayeb wrote:
Yeeloong-base also pulls in grub-yeeloong because it's a nicer boot
loader than PMON. It's slow, but I hear that's a lot better in newer
versions of GRUB (should even be usable as a firmware replacement for
PMON). We haven't got around to updating it yet.


Yep, I read that. Vlad regularly keeps us up to date about Yeeloong stuff in GRUB in #gnewsense-dev. He implemented GRUB as firmware some months ago, but so far I've not heard about anyone else who tried it. It's not that I don't trust him to get it right, but if flashing does go wrong the chip needs to be replaced, which requires some work, skill and a new chip.

Suspend and hibernate work for me with both .35 and .37. Make sure you
edit the swap partition in /etc/fstab for .37. Do you get any error
messages (check dmesg)?

After trying "suspend to ram", dmesg says:

ata& SRST failed (errno=-16

After tried to hibernate, the dmesg says:

PM: thaw of devices complete after 322.949 msecs
PM: Cannot find swap device, try swapon -a
PM: Cannot get swap writer

The swap line in /etc/fstab is

/dev/sda5 none swap sw 0 0

This said, I though that the issue was that the swap partition was
incorrectly set to 83 (instead of 82) in fdisk. I changed it and...

got the same output in dmesg

Same result after executing
swapon -a

Anyway, it's good to know that the power management is working on you
configuration. I'll investigate further here later.

fstab line looks ok to me. You could try referring to the partition with its UUID.

It seems that you have a different PMON version, so maybe that's the problem? You could try replacing it with GRUB. ;)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]