[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[gNewSense-users] Sound not working

From: sam2025
Subject: [gNewSense-users] Sound not working
Date: Wed, 10 Jul 2013 01:29:54 -0400
User-agent: Thunderbird (X11/20101029)

Hello again,

New user currently running gNewSense 2.3 (kernel 2.6.24-32) on a "p8z77-V Le Plus" Motherboard. It has sound integrated; uses "RealtekĀ® ALC889 8-Channel High Definition Audio CODEC" ( I know it works because windows has no issues with it (dual-boot). On the Realtek site, the Linux driver seems to need at least the alsa 1.0.24 version ( <>).

When running ./install everything seems fine. I make it to the "Alsa configurator version" GUI that states: "No supported PnP or PCI card found". Sound is integrated so not sure if that is an error. In any case after Reboot still no sound.

Tried to do this the manual way.
Steps below (based on other peoples' posts):

  sudo -s
  tar xjvf alsa-driver-1.0.25.tar.bz2
  cd alsa-driver-1.0.25
  ./configure --with-cards='hda-intel'
  make install
  cd ..
  rm alsa-driver-1.0.25.tar.bz2
  apt-get install libncursesw5-dev gettext xmlto
  ln -s /usr/lib/
  ln -s /usr/lib/
  ln -s /usr/lib/
  ln -s /lib/
  tar xjvf alsa-lib-
  tar xjvf alsa-utils-
  cd alsa-lib-
  make install
  cd ../alsa-utils-
  ls -lt /usr/lib/* | head
  make install
  cd ..
  rm alsa-lib-
  rm alsa-utils-

No errors that I can see. No sound after I reboot.
Looking at the "Synaptic Package Manager" I still see the alsa-base module with the old version (1.0.16 installed by gNewSense installation).

Since the install seemed to work, shouldn't at least that version have updated? Same thing happens for the alsa-lib and alsa-util, they keep their original version numbers.

There is an audio device return by "lspci -v".

  00:1b.0 Audio device: Intel Corporation Unknown device 1e20 (rev 04)
      Subsystem: ASUSTeK Computer Inc. Unknown device 841a
      Flags: bus master, fast devsel, latency 0, IRQ 14
      Memory at f7310000 (64-bit, non-prefetchable) [size=16K]
      Capabilities: <access denied>

Any ideas what else I can try to get Sound working?
thanks in advance

reply via email to

[Prev in Thread] Current Thread [Next in Thread]