[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error download hostlist

From: Guilherme Macedo
Subject: Re: Error download hostlist
Date: Sat, 26 Jun 2021 23:45:07 +0200 (CEST)

Hi Christian.

I tried to install in Debian stable, as according to the instructions in the 
doc, but it failed while trying to download the dependencies.

# apt install -f -t sid gnunet
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
gnunet : Depends: libgnunet (= 0.14.1-1) but it is not going to be installed
          Depends: libc6 (>= 2.29) but 2.28-10 is to be installed
          Depends: libgnutls-dane0 (>= 3.7.0) but it is not going to be 
          Depends: libgnutls30 (>= 3.7.0) but 3.6.7-4+deb10u7 is to be installed
          Depends: libsodium23 (>= 1.0.18) but 1.0.17-1 is to be installed
E: Unable to correct problems, you have held broken packages.

I tried to force the install, but I failed. Certainly it's trivial to fix, but 
I must admit that my Linux skills are a bit rusty. I've been using Mac for too 
long. Maybe it's time to switch back :)

So I opted for the easy way, installed Ubuntu and used the package provided by 
Taler (v0.14.1 git-2a1a812f3). It worked like a charm!

The only issue that I had, is that it complained that it could not create 
/var/log/gnunet.log. I just had to create it manually for GNUnet to finally 
work. Not sure if it's related to Taler's package or if I should open a bug 

I'll try another time to compile it again from source. Now it's time to play a 
bit with GNS and re:claimID :)

Quick question, is there a doc about which ports are needed and used by GNUnet?
I'm asking in order to harden the server and only open the needed ones in the 

Best regards.

Guilherme Macedo

25 Jun 2021, 08:12 by

> I recommend installing a way more recent package, i.e. by following:
> And then running
> # apt install -t sid gnunet
> instead of
> # apt install -t sid taler-exchange
> ;-)
> Happy hacking!
> Christian
> On 6/25/21 12:05 AM, Guilherme Macedo via Mailinglist for GNUnet
> developers wrote:
>> Hey!
>> I installed GNUnet v0.10.1 in Debian 10.10 from the package provided by the 
>> distro. However, for some reason I can't connect to the peer network since 
>> it can't download the hostlist. The returned error is:
>> hostlist-645 WARNING Download of hostlist from 
>> `' failed: `Couldn't resolve host name'
>> If I try to download it manually, I receive the same error.
>> % curl    
>> curl: (6) Could not resolve host:
>> I've read the documentation, but I couldn't find a solution. Maybe the 
>> solution is trivial, so apologies in advance.
>> Best regards.
>> Guilherme Macedo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]