[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [PATCH 7/9] btrfs: Add support for recovery for a RAID 5 btrfs profi
From: |
Daniel Kiper |
Subject: |
Re: [PATCH 7/9] btrfs: Add support for recovery for a RAID 5 btrfs profiles. |
Date: |
Thu, 18 Oct 2018 11:59:00 +0200 |
User-agent: |
Mutt/1.3.28i |
On Wed, Oct 17, 2018 at 09:03:58PM +0200, Goffredo Baroncelli wrote:
> On 17/10/2018 16.14, Daniel Kiper wrote:
> > On Thu, Oct 11, 2018 at 08:51:01PM +0200, Goffredo Baroncelli wrote:
> >> From: Goffredo Baroncelli <address@hidden>
> >>
> >> Add support for recovery for a RAID 5 btrfs profile. In addition
> >> it is added some code as preparatory work for RAID 6 recovery code.
> >>
> >> Signed-off-by: Goffredo Baroncelli <address@hidden>
> >> ---
> [...]
>
> >> +
> >> + for (failed_devices = 0, i = 0; i < nstripes; i++)
> >> + {
> >> + struct grub_btrfs_chunk_stripe *stripe;
> >> + grub_disk_addr_t paddr;
> >> + grub_device_t dev;
> >> + grub_err_t err;
> >> +
> >> + /* after the struct grub_btrfs_chunk_item, there is an array of
> >> + struct grub_btrfs_chunk_stripe */
> >
> > /* Struct grub_btrfs_chunk_stripe lives behind struct
> > grub_btrfs_chunk_item. */
>
> What about
>
> /* The struct grub_btrfs_chunk_stripe array lives behind struct
> grub_btrfs_chunk_item. */
Works for me.
> [...]
>
> >> @@ -921,17 +1061,29 @@ grub_btrfs_read_logical (struct grub_btrfs_data
> >> *data, grub_disk_addr_t addr,
> >> grub_dprintf ("btrfs", "reading laddr 0x%" PRIxGRUB_UINT64_T "\n",
> >> addr);
> >>
> >> - for (i = 0; i < redundancy; i++)
> >> + if (!is_raid56)
> >
> > Why not "if (is_raid56)"? I asked about that earlier. Please change
> > this if and of course code below. It will be much easier to read. And
> > you do not need curly brackets for for loop after else.
>
> Frankly speaking I don't see any problem having a if (!...). However I
> update the code as your request, hoping to speedup this patch set
OK, it works. However, if you have "else" below then I think that it is
more natural to drop "!" here. If you would not have else I would not
complain. Well, because it would not make sense to do so... :-)))
Daniel
- Re: [PATCH 4/9] btrfs: Avoid a rescan for a device which was already not found., (continued)
- [PATCH 3/9] btrfs: Move the error logging from find_device() to its caller., Goffredo Baroncelli, 2018/10/11
- [PATCH 5/9] btrfs: Move logging code in grub_btrfs_read_logical(), Goffredo Baroncelli, 2018/10/11
- [PATCH 1/9] btrfs: Add support for reading a filesystem with a RAID 5 or RAID 6 profile., Goffredo Baroncelli, 2018/10/11
- [PATCH 6/9] btrfs: Refactor the code that read from disk, Goffredo Baroncelli, 2018/10/11
- [PATCH 8/9] btrfs: Make more generic the code for RAID 6 rebuilding, Goffredo Baroncelli, 2018/10/11
- [PATCH 7/9] btrfs: Add support for recovery for a RAID 5 btrfs profiles., Goffredo Baroncelli, 2018/10/11
- [PATCH 9/9] btrfs: Add RAID 6 recovery for a btrfs filesystem., Goffredo Baroncelli, 2018/10/11