[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [h5md-user] observables: per particle averages or total sums

From: Felix Höfling
Subject: Re: [h5md-user] observables: per particle averages or total sums
Date: Wed, 09 Oct 2013 11:27:46 +0200
User-agent: Opera Mail/12.15 (Linux)

Am 09.10.2013, 10:26 Uhr, schrieb Pierre de Buyl <address@hidden>:

Hi Felix,

On Mon, Oct 07, 2013 at 11:21:32AM +0200, Felix Höfling wrote:
Am 04.10.2013, 21:33 Uhr, schrieb Pierre de Buyl

>The observables are stated to be "per particle". I'd like to
>revert that. There
>are situations where this is just not appropriate.
>For instance, in MPCD simulations the interaction energy
>represents energy in
>the interfacial region for which there is no clear definition of
>the number of
Such a constraint on the observables would be a bit too much, indeed. The
spec was not meant to be restrictive in this direction. The phrase "per
particle" was merely added as explanation for the standardised
identifiers, e.g., to say what is meant by "kinetic_energy". Some
considerations how to make it more flexible and still meaningful:

The file format should not enforce users to store the average instead of
the total sum, although I think it is good practice to use the average
(smaller values with a sensible normalisation and smaller round-off
errors). In your application, you could store the average along with the
varying number of particles that contributed to the average.

The data group has to be verbose about whether the average or the total
sum is stored, otherwise the information cannot be interpreted properly.

1) Very long group names like "kinetic_energy_per_particle" appear weird.

2) Making the "particles" attribute/dataset mandatory for averages
(serving as indicator) is too restrictive as well.

3) We could add an attribute "average" which is either "true" or "false",
or an attribute "type" ...

I have no definite solution for this yet. Maybe a kind of attribute would
be the best choice.

In addition to that, it would be useful to have an optional string
attribute "description" (for all data groups) which can be as precise as
the user needs/wants it to be. Such a field, of course, could not be
parsed automatically (with reasonable effort), but should make things
clear for a scientifically educated human. It could serve, e.g., as
display name for H5MD readers, by now a generic reader has to translate
the group name by replacing "_" by " ".

I thus propose that we even get rid of the suggested names. /observables is rather free as of now except for those names. Removing them would remove the
need to clarify their definitions :-)


Removing these names would void the observables group pretty much. This would be the same as leaving the identifiers "position", "image" etc. unspecified in the particles group. Such kind of groups are of little use for data exchange between different programs and not in the spirit of H5MD.

BTW, my suggestion to promote "particles" and "observables" to modules would give us much more flexibility to adjust/extend these groups later on without modifying the core definition of H5MD.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]