[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: umask doesn't work with shellcommands

From: Avi Green
Subject: Re: umask doesn't work with shellcommands
Date: Fri, 30 Mar 2001 12:04:44 -0500

> > A few days ago, I noticed that cfengine (1.5.4) seems to be running my
> > shellcommands with a umask of zero.  I tried adding the umask attribute
> > as indicated by the cfengine reference:
> > But when I run it I get "Illegal shellcommand attribute".
> This was correct behaviour and it was always intended to be
> that way,

*What* was correct behavior: the umask of zero or the error?

> but I decided to change it anyway, since so many
> people were running into trouble.

What kind of trouble were people having, and in what way did you change

> Ideally everyone should set their own umask, but no one seems to do it.

Since umasks are normally inherited from the parent process, it
shouldn't be necessary for every process to set its umask.  Most
programs rely on their inherited settings, which are usually reasonable.

> You should upgrade to 1.6.3 where you have the adittional possibilty of
> inheriting umask from shell or setting your own per process.

We will when we can, of course, but unfortunately upgrades often take a
low priority here, so I'm stuck with 1.5.4 for the time being.


= Avi Green :-) avi at (-: 212 217-1147 =
========  Unix SysAdmin & System Specialist  =========
=============  ==============
===== Netcasting Music, Videos, Film & Anime 24/7 ====

reply via email to

[Prev in Thread] Current Thread [Next in Thread]