help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Comments on upgrading FAQ


From: Matt Armstrong
Subject: Re: Comments on upgrading FAQ
Date: Thu, 14 Feb 2002 16:34:32 -0700
User-agent: Gnus/5.090006 (Oort Gnus v0.06) Emacs/21.1 (i386-debian-linux-gnu)

address@hidden writes:

> A pre-beta version a22 is now ready, and I have put out some
> updated docs and an upgrading checklist. If any brave souls
> would like to test out these and comment on them, I'd be grateful.
>
> http://www.cfengine.org/docs
>
> Most recent patches and features are included. Please be careful
> testing. Don't assume anything. Several things change now that
> we are going to be using public key encryption. I hope there's
> enough documentation to make this straightforward.

The upgrade checklist uses something called IfFileExists when setting
the CfPubKeys class.

With it I get this with 2.0.b1

cf:squeaker:/var/cfengine/inputs/cfagent.conf:79: Internal function 
iffileexists not recognized 
squeaker:/var/cfengine/inputs/cfagent.conf:Could not parse function

I ended up using the version that uses an external shell to
/usr/bin/test.

-- 
matt



reply via email to

[Prev in Thread] Current Thread [Next in Thread]