help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: editfiles not working!?


From: Alexander Mattausch
Subject: Re: editfiles not working!?
Date: Mon, 03 Jun 2002 11:52:18 +0200
User-agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.0rc2) Gecko/20020510

Marcel Ritter schrieb:

Hi there!

I recently tried cfengine and I'm quite impressed with it's capabilities.
But I ran into some trouble, when I tried to use the editfiles statement:

(The following is part of my setup):

control:
  actionsequence = ( editfiles )

editfiles:

        { /etc/inetd.conf

               HashCommentLinesMatching "^[^#]"
        }


And according to my understanding of the documentation, this should add
"#" at the beginning of each line that does not already have a # in place.


Lines that are comments already are not commented again. You can comment all lines by using

HashCommentLinesMatching ".*"

Besides, for the matching-commands to work properly you should always put a ".*" at the beginning and the end of the regular expression (if you don't want to match the beginning and the end of the line, of course).

Regards,
Alex

--

Dipl.-Phys. Alexander Mattausch
                             address@hidden
Lehrstuhl für theoretische Festkörperphysik   --   Uni Erlangen-Nürnberg
          ***   http://www.tfkp.physik.uni-erlangen.de ***

Hi! I'm a .signature virus. Add me to your .signature and join the fun!






reply via email to

[Prev in Thread] Current Thread [Next in Thread]