help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: lock files never cleared on locally copied files


From: ABostick
Subject: RE: lock files never cleared on locally copied files
Date: Mon, 2 Dec 2002 11:39:28 -0600

I had some similar issues with Solaris 8 and 2.0.4 concerning stale locks.
I upgraded to the latest 2.0.5pre and everything seems to work now :)  Try
that first...

Aaron


Subject: lock files never cleared on locally copied files (solaris 8,
        cfengine 2.0.4, funny network)
From: Ian Wallace <address@hidden>
To: Cfengine Help <address@hidden>
Date: 26 Nov 2002 13:41:20 -0700

I have a question as to if someone has seen this before.  Periodically
if I update a file in the master configuration set it doesn't copy
correctly to some machines (well it doesn't copy at all).  And cfengine
when I run it with -v complains that it can't copy b/c it's too soon
(0/1 elapsed).  Yet even when I wait for a long time (say 30 minutes) it
still says the same thing and refuses to copy the file.  Here's my
setup:

Policy host distributes files to all machines that can see it via the
network.

For machines in the DMZ where they can't connect back to the policy host
I rsync (via a shellcommands) the configuration tree and then do local
copies to move the files into place.

The machines that show this behavior are all DMZ hosts so I'm wondering
if it's an issue with that or the DB libraries are somehow messed up. 
All the other machines run like a champ.

Running with the -d2 option didn't reveal anything interesting (to me at
least).  Anyone seen this?  How do I go about debugging it?  If I run
with the -K option everything updates correctly and is moved into place.

I have also added ExpireAfter = ( 1 ) and IfElapsed = ( 1 ) to the
cfagent.conf (well cf.main however it's included in that file).

This occurs whether I run via cfrun, or cfagent locally on the
machines.  Any information would be useful.  Thanks!

cheers
ian



-- 
Ian Wallace - address@hidden
303.218.2040 (w) 720.308.5696 (m) 303.218.2100 (f)
eForce Managed Services, Denver CO 
Enterprise IT Solutions. Fixed Price. Fixed Time.







reply via email to

[Prev in Thread] Current Thread [Next in Thread]