help-cfengine
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: installing Cfengine-2.1.0p1 on RH 9 - problems


From: Chip Seraphine
Subject: Re: installing Cfengine-2.1.0p1 on RH 9 - problems
Date: Tue, 04 Nov 2003 13:29:20 -0600
User-agent: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.2.1) Gecko/20030121


This one seems to come up a lot-- maybe we should smarten up the configure script? :-)

The problem is that some Linuces (SuSE, RH) insert a hyphen into the library name. Take a look at your config.log and the actual tests in the configure script for details.

You can try this to work around the problem: Find where your db files are located ("rpm -ql db" should do it) and you should see something some files with a name like "lidb-4"... . Set a symlink to the library without the dash (i.e. "libdb4") and it should be ok.



Achanta, Venkata Phani wrote:
hello,

i am trying to
configure cfengine-2.1.0p1 on RH 9 with BerkelyDB version 4.1 and openssl-0.9.7c

The configure script aborts saying

checking for BerkeleyDB location../usr/local/BerkeleyDB4.1
checking Berkeley DB version ...configure: error:This release of cfengine 
requires BerkeleyDB 3.2 or later

As you can see i have BerkeleyDB4.1 installed in my /usr/local.
i dont know what the problem is i have to get this to work.

Please help me in installing the cfengine ASAP...


Thanks
Venkata



_______________________________________________
Help-cfengine mailing list
address@hidden
http://mail.gnu.org/mailman/listinfo/help-cfengine






reply via email to

[Prev in Thread] Current Thread [Next in Thread]