[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Lock expiration problem

From: Atom Powers
Subject: Lock expiration problem
Date: Fri, 21 Apr 2006 13:10:45 -0700

With cfe 2.1.17 on FreeBSD 5.4 and 6.0 I am having a serious problem
with lock expiration. I find that every day several of my systems
cfengine isn't doing anything. When I run it manually with `cfagent
-qv` I see something lik this:

cfengine:charon: Lock lock.cfagent_conf.charon.resolve._3105 expired
(after 890/90 minutes)
Trying to kill expired process, pid 26434
Checking config in /etc/resolv.conf
cfengine:charon: Moved /etc/resolv.conf.cfsaved to repository location

cfengine:charon: Lock
expired (after 1310/90 minutes)
> grep cfe /etc/crontab
# Excec cfengine
0       *       *       *       *       root    /var/cfengine/bin/cfexecd -F
> grep Expire /var/cfengine/inputs/cfagent.conf
ExpireAfter             = ( 90 )

I have tried disabling the sections that I usually see those messages
on, but the lock just moves to another part of the config process and
I still have the problem.

Is there something I can look for in my config that may be causing this?
Is there an option to cfexecd that will kill these locks when it is supposed to?

Perfection is just a word I use occasionally with mustard.
--Atom Powers--

reply via email to

[Prev in Thread] Current Thread [Next in Thread]