[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gmake troubles under Win XP -- opening shells instead of executing c

From: Stan Brown
Subject: Re: gmake troubles under Win XP -- opening shells instead of executing commands
Date: Sat, 09 Jul 2005 21:16:19 -0400

On Wed, 15 Jun 2005 11:13:51 -0700, "Damian Stones"
<> wrote:

>"Stan Brown" <> wrote in message
>> Windows XP Pro with SP2
>> GNU Make version 3.79.1, by Richard Stallman and Roland McGrath.
>> Built for i386-pc-msdosdjgpp
>> Since I changed from Win 98 to Win XP, gmake has been behaving in
>> all sorts of flaky ways. I'd be very grateful if somebody can tell
>> me what is wrong.
>> (One thing that makes this hard to diagnose is that the output of
>> "make -n" is, amazingly, _not_ the commands that make actually
>> executes without the "-n". It sure would be nice if there were some
>> way to find out what commands MAKE is actually executing.)
>> When I run it with "make 4INDEX.HTM -n" it correctly displays the
>> commands that I expect to see, namely
>> > ver
>> > echo f:\ors\code\makesub ./ 4INDEX.HTM ./ 4INDEX.HTM ./4.DEF 4INDEX.0
>> > f:\ors\code\makesub ./ 4INDEX.HTM ./ 4INDEX.HTM ./4.DEF 4INDEX.0
>> But when I type "make 4INDEX.HTM" without the -n, things go flaky.
>> (a) MAKE opens a new command shell and then leaves me with a user
>> prompt.
>> (e) As mentioned above, "make -n" doesn't actually show the
>> commands that make executes without the "-n".
>> I'm completely at a loss. I'll be happy to provide additional
>> information or run additional tests if someone can help me track
>> down and ultimately fix this problem.

>Very late reply - and possibly of no use to you whatsoever but are you
>making sure to tell GNU Make to use Win32 command line options when invoking
>the shell? You need to add the option "-win32" (no quotes) otherwise when it
>invokes your command shell to execute a command,  it doesn't start in
>immediate mode and opens a window for user input...

Thanks for the reply. I tried -win32 on the make command line, and
it responded with a list of options (which didn't include that one).
I tried -win32 on a command line inside my rules, and the symptoms
were still the same.

It would help in diagnosing this if I could find out what commands
MAKE actually passes to the command processor. Does anyone know how
to do that, short of altering the source code and recompiling?

Stan Brown, Oak Road Systems, Tompkins County, New York, USA
"My theory was a perfectly good one. The facts were misleading."
                                   -- /The Lady Vanishes/ (1938)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]