[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Koha-devel] Koha installation problem

From: albert
Subject: [Koha-devel] Koha installation problem
Date: Thu Aug 7 07:51:11 2003


I install your koha library system into my Linux server8.0. I meet the 
following problem. I would like you to give me some suggestions to solve it.

To ensure that I have start the MySQL dataabase by ' mysql -ukoha -pkohapass 
Koha ' ,perl is worked well in my workstation and I have also instaled 
Then I follow your installation guide, I untar the software. I follow the 
step until I make the opac/cgi-bin in /var/www/cgi-bin and opac/htdocs 
in /var/www/html. Copy koha/opac-cgi/* into opac/cgi-bin, koha/opac-html/* 
into opac/htdocs, copy the koha.conf into /etc and koha/modules/C4 
into /usr/lib/perl5/site_perl/5.8.0/i386_linux. 

When I use the browser to run the library system. 
http://domain.com/cgi-bin/opac/cgi-bin/opac-main.pl , it shows :

Server error!
The server encountered an internal error and was unable to complete your 
Error message: 
Premature end of script headers: opac-main.pl 
If you think this is a server error, please contact the webmaster 
Error 500
Thu 07 Aug 2003 02:44:02 PM HKT 
Apache/2.0.40 (Red Hat Linux) 

When I ues command in linux text mode,
perl opac-main.pl    ,   it shows :

HTML::Template->new() : Cannot open included file /htdocs/default/en/opac-
main.tmpl : file not found. 
at /usr/lib/perl5/site_perl/5.8.0/HTML/Template.pm line 1580
called at /usr/lib/perl5/site_perl/5.8.0/HTML/Template.pm line 1177
        HTML::Template::_init('HTML::Template=HASH(0x8283a08)') called 
at /usr/lib/perl5/site_perl/5.8.0/HTML/Template.pm line 1071
main.tmpl','die_on_bad_params',0,'global_vars',1,'debug',0,...) called 
at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/C4/Output.pm line 
        C4::Output::gettemplate('opac-main.tmpl','opac') called 
at /usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/C4/Auth.pm line 45
        C4::Auth::get_template_and_user('HASH(0x83feb3c)') called at opac-
main.pl line 11

The problem I post above. It confuses me for period of time. And I have 
tried to find some solution in Google or Yahoo. But no one can help me. 
Please help me to give me suggestion to solve. If you want any other 
details, I will re-send to you immediately.

best regards,
Albert Lee

reply via email to

[Prev in Thread] Current Thread [Next in Thread]