[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Koha-devel] strange problem with passing $dbh value

From: Chris Cormack
Subject: Re: [Koha-devel] strange problem with passing $dbh value
Date: Wed Apr 7 13:32:03 2004
User-agent: Mutt/

On Tue, Apr 06, 2004 at 01:56:25PM -0400, Stephen Hedges said:
> I need a clue...
> I'm having a problem with import of bulk MARC records.  We just moved all
> the Nelsonville Library Koha stuff to a new machine on Sunday, where we
> are now using the new 2.0 release.  (Our old production machine had a
> pasted together collection of Koha stuff, some of it 7 months old.)  In
> the process we also moved our MARC import script.
> Now something weird is happening.  When I try to run the script as any
> user other than root, it fails because the bulkmarcimport call to the
> &MARCfind_marc_from_kohafield function in Biblio.pm is not passing the
> $dbh value.  So Biblio.pm throws a 'no database' error:
> DBD::mysql::st execute failed: No Database Selected at
> /usr/local/koha/intranet/modules//C4/Biblio.pm line 258.
> (same error happens later in the script at Biblio.pm line 858)
> If I "su" to superuser and try running the script again, it works.  (On
> our old machine, it worked either way.)
Hi Stephen

My guess is its the permissions of /etc/koha.conf if it isnt readable as
the user you run as, this might be the problem.

Chris Cormack                                                     Programmer
027 4500 789                                       Katipo Communications Ltd
address@hidden                                          www.katipo.co.nz

reply via email to

[Prev in Thread] Current Thread [Next in Thread]