[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Linphone-users]Bugs in Linphone (Route Header+shutdown hangs)

From: Aymeric Moizard
Subject: Re: [Linphone-users]Bugs in Linphone (Route Header+shutdown hangs)
Date: Tue, 4 Feb 2003 14:12:42 +0100 (CET)

On Tue, 4 Feb 2003, Klaus Darilion wrote:

> Hello!
> I used linphone 0.9.1 and 0.10.0 and every time i tried to call someone
> via the ser proxy from iptel I get the error message from the proxy: 404
> User not found.
> I analysed the headers of the invite message and found a route header in
> the invite.
> INVITE sip:address@hidden SIP/2.0
> Via: SIP/2.0/UDP;branch=z9hG4bK980238535
> Route: <;lr>
> From: <sip:address@hidden>;tag=1723191228
> To: <sip:address@hidden>
> Call-ID: address@hidden
> CSeq: 20 INVITE
> Contact: <sip:address@hidden:5070>
> max-forwards: 10
> user-agent: oSIP/Linphone-0.10.0
> Content-Type: application/sdp
> Content-Length: 330
> Then I sent the invite without the route header and everthing works fine
> - so is the route header misplaced in an invite? Yes! Because there must
> not be a route header in a request (for example INVITE) without an
> existing dialog because we don't know yet which proxy will add the
> "Record-Route" header. (RFC3261 section 12: Dialogs)

Not true.
The Route header is a "pre-route set". This is the compliant way to
send an initial request to a specific outbound proxy.

We have also noticed that the sip server also
refuse this option.

To avoid this issue, you can just disable the "outbound proxy"
and enable the "proxy server" one in the SIP configuration of
linphone. The behavior will be the same but the route header
will not be included in the initial request.

If you still get problems, let me know.

I can't help for your second issue.

> Conclusion: There must not be a "Route" Header in the first INVITE
> request.
> Second Problem:
> Almost always when I quit linphone 0.10.0 it crashes. Linphone says:
> | INFO1 | <ict_callbacks.c: 233> OnEvent_New_Incoming4xxResponse!
> | INFO1 | <utils.c: 92> info: Name resolution requested.
> LinphoneCore-Message: Registration sent.
> | INFO1 | <resolver.c: 111> Doing asynchronous name resolution.
> And then the GUI doesn't respond anymore and I have to kill the
> application with CTRL-C in the terminal. I use Linphone 0.10.0 with
> RedHat 8.0.
> Regards,
> Klaus
> _______________________________________________
> Linphone-users mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]